Caravan
cw

Sunlight T67 - Ersatz einer 2 AufbauBatt durch LiIon 1, 2, 3, 4, 5, 6


George67 am 21 Okt 2019 16:20:34

Nein, das nützt nix oder wird schlechter. Ich glaube, du hast Rückwirkungen vom Strom. Masseleitung und so.

Anzeige vom Forum

Hier findest Du vielleicht schon, was Du suchst: --->Link

Albrecht0803 am 25 Okt 2019 09:08:22

Die x-te Neuauflage des Spannungssensors ist jetzt außerhalb der Hauptplatine erfolgreich getestet. Habe allerdings festgestellt, daß der 8V-Spannungsregler 7808 zusammen mit dem OpAmp 2,5mA zieht. Da diese Teile permanent, noch vor dem Abtrenn-Mosfet am AGM-Block hängen, ist mir das eigentlich zuviel.

Vielleicht ersetze ich den Regler doch wieder durch die Emitter-Schaltung eines NPN-Transistors mit Zenerdiode als Spannungsreferenz.

Nächster Schritt am Wochenende: Betrieb des Sensors an der Relais-Hauptplatine. Dann sukzessives Aufschalten von zunächst Boost, dann Li-Block, dann Buck und Agm. Die Batterien erst mal wieder in kleinen Kapazitäten, bis das alles ordentlich schaltet.

George67 am 25 Okt 2019 14:51:13

Albrecht0803 hat geschrieben:Die x-te Neuauflage des Spannungssensors ist jetzt außerhalb der Hauptplatine erfolgreich getestet. Habe allerdings festgestellt, daß der 8V-Spannungsregler 7808 zusammen mit dem OpAmp 2,5mA zieht. Da diese Teile permanent, noch vor dem Abtrenn-Mosfet am AGM-Block hängen, ist mir das eigentlich zuviel.


Du musst nach 78L08 (L für Low Power) suchen.
Hatte ich dir so angegeben.... :D

--> Link

0,2 mA für den Regler. OP findes du auch kleiner 1 mA. Übertreibs nicht, ich habe 40 mA mit meinem Wandler, im Dauerbetrieb... selbst das fällt erst nach >10 Tagen auf.

Albrecht0803 am 25 Okt 2019 18:15:27

Hatte ich nicht beachtet und einfach den nächstbesten 7808 bestellt... wird korrigiert, Danke!

Der Op-Verstärker ist schon ein sparsamer Typ mit 0,06mA lt. Datenblatt.

George67 am 25 Okt 2019 18:34:39

Jaja, es sind oft die Kleinigkeiten.

Bei der 3. Tour hab ich Jetzt auch noch was gefunden.

Albrecht0803 am 27 Okt 2019 18:41:37

Es geht immer langsamer voran, als man sich das vorstellt.

Zunächst die Spannungsregler: die 78L08 haben auch lt. Datenblatt schon ein paar mA Ruhestrom und wie sich rausstellte, hatte ich im Dusel schon die richtigen bestellt...

Es gibt noch eine andere Serie, deren Ruhestrom im müA-Bereich liegen soll: LP2950.

Die gibt es als Festspannungsregler, allerdings nur mit 5V und 3,3V. Und als IC, das eine regelbare Spannung ermöglicht.

Leider habe ich den Tag mit dem regelbaren Aggregat vertan, ohne daß da am Output die gewünschte Spannung rauskam.
Dann halt enen 5V und einen 3,3V-Regler kaskadiert, was dann fast auf Anhieb funktionierte. Man braucht eine Minimallast, sonst mißt man am Ausgang praktisch die Eingangsspannung...

Das Ding funktioniert jetzt soweit und die Hauptrelaisplatine wird korrekt angesteuert. Die Wandler sind noch nicht dran, das kommt dann als nächstes. Der Eigenverbrauch des Spannungssensors im nicht durchgeschaltetem Zustand liegt bei 0,2mA. Das zumindest ist erfreulich.

George67 am 29 Okt 2019 11:15:12

Du musst keine 8 V nehmen, 5 V reichen auch. Lässt du den OP Auf 12 V oder auf der stabilisierten Spannung laufen?

George67 am 29 Okt 2019 12:28:45

Noch ein Ratschlag.
Steck nicht zuviel Arbeit in den Ruhestrom Verbrauch. Das ist nicht dein Hauptproblem. Du baust nen Prototyp, der eh verbessert und verändert wird. Teste das Grundkonzept der Wandler.
Ich will eh eine Rechner Steuerung haben, und ich sorge für geringen Stromverbrauch. Die kannst du später haben.

Albrecht0803 am 30 Okt 2019 14:34:58

Der Verstärker läuft auf den stabilisierten 8V. An Deiner Steuerung später bin ich auf jeden Fall interessiert. Den ganzen Zauber analog zu schalten mag zwar gehen, aber bis alles läuft geht mir inzwischen mehr Zeit drauf als gedacht.

Aktuell klappt das Einschalten des Boosters. Der Li-seitige Mosfet-Schalter schaltet nicht durch. Ich glaube, die Ursache per Simulation schon gefunden zu haben. Anpassung eines Widerstands...

Albrecht0803 am 30 Okt 2019 17:44:09

Also, am gateseitigen Widerstand lag es nicht. Dafür war der Emitter des Vorschalttransistors gar nicht angelötet. Trotzdem klappt es noch immer nicht. Werde die Tochterplatine schrittweise neu aufbauen, erst mal nur den Transistor erfolgreich durchschalten. Dann die Mosfets dran.

Ich glaube, in diesem Projekt habe ich jeden denkbaren Fehler schon mal gemacht!

George67 am 31 Okt 2019 16:02:20

Albrecht0803 hat geschrieben:
Ich glaube, in diesem Projekt habe ich jeden denkbaren Fehler schon mal gemacht!

Den Lerneffekt kann dir niemand nehmen. Und glaube doch nicht, dass ich fehlerfrei baue.....

Albrecht0803 am 31 Okt 2019 19:08:35

Heute den Tag am Womo gebastelt. Habe so ein System zum Freiblasen der Wasserleitungen mittels eines kleinen Kompressors. Mit einigen listigen Ventilen kann man es auch zum Befüllen von Fahrradreifen verwenden. Letzteres sollte geschehen, aber der Kompressor blieb stumm.

Habe die halbe Karre zerlegt um die Kabel durchzumessen. Am Ende waren es korrodierte Kontakte direkt im Schalter des Kompressors. naja.

Ein neuer Mosfet-Schalter für das Li-Projekt ist dennoch entstanden. Und erfolgreich zunächst ohne die Hauptschaltung getestet. Der Zusammenbau erfolgt dann morgen.

Albrecht0803 am 01 Nov 2019 23:26:49

Der Li-seitige Mosfet-Schalter ist mit der Hauptplatine verbunden und scheint zu funktionieren. Der Booster ist angeschlossen und wird mit dem Spannungssensor gesteuert.

Es wird als nächstes der Dummy-Li-Block (10s1p) angeschlossen. Danach der Buck-Wandler und zum Schluß der Blei-Test-Block. Im Moment dient das Labornetzteil als Ersatz für beides, die Bleibatterie und die Lichtmaschine. Wenn das alles funktioniert, kann man auf die echten Batterien übergehen.

So allmählich komme ich drauf, daß man die Schaltungen immer nach kleinen und kleinsten Baufortschritten sofort testen muß. Brät man erstmal alles zusammen und funktioniert irgendwas nicht, ist es fast unmöglich, den Fehler zu finden. Und wenn man ihn dennoch findet, ist die Reparatur dieser Lochrasteraufbauten anschließend ein Schlachtfeld...

Langsam sollte ich mir Gedanken machen, wohin mit der ganzen Apparatur im Auto. Unter dem Beifahrersitz ist kein Platz mehr, da dort schon eine zweite AGM installiert ist, die ich ungern rausschmeißen würde. Hat schließlich auch mal gute, geliebte Taler gekostet! Vielleicht unter der Sitzbank, direkt neben Heizung und Boiler? Das heißt dann allerdings Strippenziehen, auch nicht grade das liebste Hobby.

Albrecht0803 am 02 Nov 2019 20:01:40

Neuer Zwischenstand: Laden der Li-Zellen auf Basis der Spannungssensor-Ladestromerkennung klappt auch. Nächster Test: Ansteuerung der Batterie-Heizung bei nicht ausreichender Temperatur. Der Temperaturschalter an sich funktioniert. Es muss die Heizleistung (ca. 120W) ohne Erwärmung der Mosfets durchgeleitet werden. Das wird morgen getestet.

Danach kommt der Buck dran. Da erwarte ich erstmal keine Überraschungen. Erst wenn der Bleiblock auf der 12V-Seite drangeklemmt wird, könnte es nochmal interessant werden, wegen der höheren Ströme. Als letztes muß ich leider den digital einstellbaren Buck durch einen mit Trimmpotis ersetzen, da der Digitale immer wieder einen manuellen Druck auf den Einschaltknopf braucht, wenn vom Boost auf den Buckbetrieb zurückgeschaltet wird. Die digital gespeicherten Werte würde er behalten, aber das händische Einschalten disqualifiziert ihn leider.

George67 am 08 Nov 2019 15:36:12

Ich habe meinen Buck-Wandler tauschen müssen. Die Eingangselkos haben Überspannung gesehen (>50 V), aufgebläht.
Die Forensik hat ergeben, dass das wieder ein Schmutzeffekt ist (sein muss), der mit der merkwürdigen Masseunterbrechung des Boost zu tun hat. Kommt dann zur Wirkung wenn man in der falschen Reihenfolge 12v und 36 V Kreis auftrennt, und dann doch noch ein "Pumpen". auftritt.

Ich werde also einen zusätzlichen Mosfet Schalter einbauen, der den Buck abtrennt, am besten natürlich die 12 V.
Muss ich was vorhandenes modifizieren.
Das Schaltsignal werde ich mir aus dem Buck holen, mit zusätzlicher Totzeit, damit die Steuerung einheitlich ist.
Und ich habe den Einsatz des Boost noch höher gestellt, um den Totbereich zu vergrößern.

Albrecht0803 am 08 Nov 2019 19:18:49

Habe in der Simulation so lange rumgespielt, bis man die fiktiven Verbindungen der Masseseite von buck und boost wegnehmen konnte, ohne dass sich das Schaltverhalten ändert. Meine Mosfet-Strecken reagieren recht empfindlich darauf.

Als günstig (in der Simulation) hat sich die Überbrückung der Massestrecke des Boosters mit einem 100k Widerstand erwiesen. Das sollte evtl. Strommessungen auf dieser Strecke nicht beeinflussen. Vielleicht hilft das auch gegen überspannungen?

Morgen wird die Hardware dementsprechend angepasst. Aktuell kriegte ich den Buck nicht ans Laufen, wahrscheinlich weil der 36V-Mosfet-Schalter nicht wirklich aufgemacht hat...

George67 am 08 Nov 2019 19:55:35

Werd ich mal testen.

Albrecht0803 am 10 Nov 2019 10:16:12

Allmählich überkommt mich die Verzweiflung: Nachdem es zum Basteln in der Garage zu kalt geworden war, und das Labor ins Haus portiert wurde, kommen alle die überwunden geglaubten Effekte wieder zum Vorschein. Hauptsächlich das mit Recht so beliebte Takten bei Spannungen knapp oberhalb der Ladeerkennungsspannung.... Die Hysterese, um das wegzukriegen ist allerdings zu hoch.

Gestern kam ein Paket mit diversem Arduino-Kram. Ich werde das mal digital aufsetzen. Das Simulationsprogramm kennt den Arduino als Schaltungselement. Da kann man die Software schon mal in der Simulation antesten, was auch schon funktioniert. Ich denke, dieser Weg könnte die Lösung sein. Kein Gebastel mehr mit driftenden Spannungssensoren. Einzig der Eigenverbrauch ist deutlich höher. Sollte aber nicht stören, wenn man das Konzept der Mosfet-Schalter wie in dem bisherigen Konzept beibehält. Dann wird der Arduino im Nicht-Gebrauchszustand halt einfach mit abgeschaltet. (Entspricht dem Zustand „Hauptschalter aus“.)

George67 am 10 Nov 2019 11:19:33

Albrecht0803 hat geschrieben:.......kommen alle die überwunden geglaubten Effekte wieder zum Vorschein. Hauptsächlich das mit Recht so beliebte Takten bei Spannungen knapp oberhalb der Ladeerkennungsspannung.... Die Hysterese, um das wegzukriegen ist allerdings zu hoch.


Jetzt muss ich dich, mit allem Respekt, mal einbremsen. Verschwende deine Zeit nicht an Dingen, die weder zu ändern sind, noch wirklich notwendig.

Lass ihn "Takten".

Viele mögliche Ursachen, auf denen das Takten beruht: (Alles im Nahbereich des Hysterese-Schwellwertes, z.B. 13,2 V)

1) Innere Funktion des Wandlers: Es wird eine Spule solange mit "Strom" aufgeladen, bis der Strom dem Doppelten (!) des Nennstroms - oder des eingestellten - Stroms entspricht. Das können im ungünstigen Fall 60 A sein, im günstigen dem doppelten deines Nennstromes. ( 5 A ?) Dabei entsteht ein Spannungsabfall über die Zuleitung, und den Innenwiderstand des Akkus. Wenn diese Spitzen die Hysterese unterschreiten, dann taktet er.

2) Er taktet also auch dann, wenn deine Quelle (die den Akku stützt bzw. läd) eigentlich mehr Strom liefern könnte.

3) Er taktet vor allem auch dann, wenn deine Quelle in der Strombegrenzung ist (Solar) bzw CC). Er taktet sogar dann, wenn die Hysterese dabei nicht unterschritten wird, weil du ja beachten musst, ob der Akku (vorher) den Ladestrom von ein paar Amp bekommen hatte, und DABEI die 13,2 V hatte. Ziehst du den Strom jetzt vom Akku ab, fällt die Spannung natürlich....

4) Ob und wie er taktet, hängt auch davon ab, wie die innere Strombegrenzung des Boosters arbeitet. Fährt er wirklich die Strombegrenzung der Spulenladung zurück, oder taktet er selber nur den Mittelwert des Stromes ? Dann hättest du GARKEINE Chance, das Takten zu verhindern.

Alle diese Effekte werden schwächer, wenn die Spannung sich nach oben vom Schwellwert entfernt. Und es ist auch klar warum - der Schwellwert wird seltener oder kürzer unterschritten.

Nimm das Takten als natürlichen Effekt, mit dem das Gesamtsystem die transportierte Leistung an das Stromangebot der Quelle ( Blei plus Ladestrom) anpasst. Versteh dass Takten als PWM (Pulsweitenmodulation) des Stromes als digitalen Stromregelvorgang.

Und gut is.

Da ist tatsächlich, so kann man es sehen, eine "analoge Kennline" der Spannung über dem Schwellwert zu einer PWM des Stromes. Ist ein interessanter Effekt.

Je nachdem, welcher der obigen Effekte greift, kriegt also auch der Ardu das nicht weg. Nur mal so zur Warnung.....

Albrecht0803 am 10 Nov 2019 17:34:38

Schon klar, wenn die Spannung durch den Einschalt- oder Lastrom einbricht, kann der Sensor natürlich zum Takten kommen. Es gibt zwei in der Praxis bestätigte Maßnahmen das zu verbessern: Hysterese vergrößern und/oder Spannung deutlich über die Schaltschwelle anheben.

Und natürlich die Leitungsquerschnitte...

Also, mangels wirklicher Last auf dem Booster habe ich das Takten mit der entsprechend getriggerten Schaltschwelle der Akkuheizung (glaube ca. 150Watt) provozieren können. In der Simulation trat es nur auf, wenn irgendwo in der Zuleitung ca. 0,5 Ohm Leitungswiderstand eingebracht wurde. Aber auch dann mit viel höherer Frequenz als in Wirklichkeit. In der Simulation habe ich die Lasten durch entsprechend hoch gesetzte Verbraucher, die Glühlampen, modelliert. Bis ca. 400 Watt (Nennleistung, wird auf der 12V-Seite nicht erreicht) war das alles beherrschbar.

Werde die analoge Lösung auf jeden Fall zum funktionierenden (möglicherweise halt taktendem) Abschluß bringen. Vermutlich hilft es auch, die Schaltschwelle möglichst niedrig zu legen, durchaus mit kleiner Hysterese. Wenn dann Ladeenergie zur Verfügung steht, ist die Spannung hoffentlich gleich deutlich über der Umschaltschwelle, etwas, was man beim Hochdrehen der Spannung am Labornetzteil, ja nicht in gleicher Weise nachbildet.

Vom Arduino verspreche ich mir die Möglichkeit, tiefpassmäßig ins Geschehen eingreifen zu können, oder die Schaltgrenzen evtl. adaptiv anzupassen oder von den gemessenen Gradienten der Spannungen abhängig zu machen. Man kann auch mit möglichen Schaltreaktionen warten, bis sich alle Zustände nach einem Umschaltvorgang eingeschwungen haben. Hauptvorteil aus Bastlersicht ist natürlich, daß man eigentlich kaum was an der Hardware ändern muß, fast alles läuft über die Software.

Der Ersatz des Spannungssensors durch eine entsprechende Messung und Schaltreaktion mittels Arduino, inkl. einstellbarer Hysterese ist mit ca. 10 Zeilen Code möglich und in der Simulation auch schon implementiert. Der Rest der Hardware, die ganzen lastschaltenden Relais bleiben unverändert, ebenso wie die Mosfet-Strecken zum Totlegen der Schaltung.

Gut, in C bin ich als alter Fortran-Stratege nicht so souverän unterwegs, aber für die Parameteranpassung eines 3D-Druckers vor ein paar Jahren hat es schon mal gelangt, auch wenn mir der Sinn des Befehls void mit seinen geschweiften Klammern auf ewig unverständlich bleiben wird!

Auch meine Kopter fliegen fast alle mit Arduino-Hardware, wobei ich die allerdings nichts selbst programmiert habe....

George67 am 10 Nov 2019 21:29:55

Ich kann dir sagen, dass der boost ne ziemliche Hysterese hat, über 200 mV, und auch mein kräftigen Tiefpass drauf, 200 ms oder mehr.
Ich hab gerade den Wandler in einer Testumgebung. Aber niedriger Strom. Der taktet brav, und mit ein paar mV mehr geht er in Dauerbetrieb. Nichts daran missfällt mir..
Da ist auch ein Signal, das ich zur Abschaltung des Buck nehmen kann, ist nur invertiert. Aber richtig träge, sehr gut.
Mal sehen.

Albrecht0803 am 10 Nov 2019 23:02:58

Hi Georg,

dann lass ich mein System halt auch takten. Obwohl es sich wegen der vielen Relais wie ein Blinkerknacken anhört. Du hast schon recht, wenn man die Geschichte als automatische Kennlinienanpassung auf Basis einer PWM-Aufteilung ansieht, liegt es gleich nicht mehr so schwer im Magen... ;-)

Was ich eigentlich ursprünglich mit dem Arduino vorhatte, war, die Relais komplett zu ersetzen und stattdessen Mosfet-Strecken mit eindeutiger Orchestrierung durch den Arduino einzusetzen. Nicht wie jetzt mit irgendwie hingepfriemelten und notdürftig pegelmäßig aufbereiteten Analogsignalen.

Das kommt dann auch noch, aber später.

George67 am 14 Nov 2019 10:30:46

(Eigenzitat)
George67 hat geschrieben:Ich habe meinen Buck-Wandler tauschen müssen. Die Eingangselkos haben Überspannung gesehen (>50 V), aufgebläht.
Die Forensik hat ergeben, dass das wieder ein Schmutzeffekt ist (sein muss), der mit der merkwürdigen Masseunterbrechung des Boost zu tun hat.



Die Analyse war falsch. Ich habe endlos davor gesessen und gemessen, bis ich der wahren Ursache auf die Schliche gekommen bin.

Es Ist natürlich vollkommen logisch, das Überspannung auf der 36 V Seite nur vom Boostwandler erzeugt werden kann.
Aber es ist falsch!

Es war der Buckwandler selber, der rückwärts gearbeitet hat und sich selber die hohe Spannung auf der Eingangsseite erzeugt hat, und sich selber abgeschossen hat.
Also, schlussendlich habe ich gefunden, dass dieser (Buck)Wandler, selber auf der EINGANGSseite eine höhere Spannung ausgeben kann (als 40 V), wenn ich auf der AUSGANGSseite eine höhere als die eingestellte Spannung (12,8 V) einspeise. Genau das mache ich ja, er ist an der Bleibatterie angeschlossen, auf 12,8 V eingestellt, darunter soll er speisen. Und geht die Spannung höher als diese 12,8 V, soll er einfach nichts machen.
Meine vorherigen Wandler (aus der ersten Proto-Wandlergeneration) haben das auch so (nichts) gemacht - dieser nicht (!).

Dieser arbeitet tatsächlich auch rückwärts (!), er ist also ein bidirektionaler Wandler.
Ich konnte ihm das abgewöhnen, im Moment brauche ich das nicht. Aber ich werde mir das in der nächsten Version sicher genau ansehen, ob man mit diesem einen Wandler nicht beide Transferrichtungen der Leistung abdecken kann. Das wäre es ja - ein modifizierter 6-Euro-Wandler als komplettes Leistungsteil....

Ich bin mal gespannt, wer das interessant findet. :D

Für Albrecht und Elektronikeingeweihte:
Der Wandler arbeitet mit einem LM25116. Das englische Datenblatt gibt es hier:
--> Link

Das interessante ist, dass diese Wandler nicht mit eine Schottkydiode im Leistungskreis arbeitet (wie die integrierten Wandler wie XL4016), sondern dort einen zweiten (N-)Mosfet hat, der die Diode durch geschickte Ansteuerung simuliert. Vorteil ist, dass man nicht die Verlustleistung durch den Spannungsabfall von ca 0,5 V mal Strom (10-20 A) hat, sondern nur den des niederohmigen Mosfet (plus Schaltverluste).
Das ganze nennt sich Syncronous Mode (im Datenblatt Seite 20), und genau der kann die Leistung aus der Spule auch in den Hochvoltkreis hineinschieben statt dort welche herauszuholen - ein Frage des Timings bei der Ansteuerung der Mosfets.
Schlauerweise kann das IC aber auch einen sogenannten "Diode Mode", der zum Einschalten vorteilhaft ist, und bei dem der Rückfluss von Energie nicht möglich ist..... und das kann man durch externe Beschaltung auch noch gezielt einstellen.
Der Ersatz eines 10 kOhm Widerstands durch einen Kurzschluss hat in diesem Falle den ganze Spuk beseitigt.
Das Teil ist bald wieder im Womo und darf schon nächste Woche wieder in den Dauertest.

Albrecht0803 am 14 Nov 2019 16:35:39

Moin Georg,

das sind ja wahre Krimis mit dieser Schaltung. Wenn es tatsächlich gelänge, mit dem Buck Energie rauf oder runterzuschieben, wäre das natürlich der Clou. Je nachdem, ob die Blei-Spannung ober- oder unterhalb der Buck-Ausgangsspannung ist, stellt sich die entsprechende Richtung von alleine ein. Das ist doch genau, was wir mit dem Li-Konzept erreichen wollen.

Selbst wenn man den vorhandenen Wandler nicht zu dieser Arbeitsweise umstricken kann, würde es sich vielleicht lohnen, einen mit passenden Specs selbst zu designen?

Für meine Schaltung stellt das von Dir beobachtete Verhalten des bucks im Moment kein Problem dar, da er definitiv nur im Transfermodus zur Bleibatterie hin eingeschaltet ist. Ein wenig weiter bin ich schon gekommen, die Mosfet-Strecke Li-seitig muß wohl noch etwas anders angesteuert werden.



Immerhin schaltet sich der Buck schonmal ein, wenn die Spannung dem „nicht-Ladezustand“ entspricht.

George67 am 15 Nov 2019 16:21:33

Albrecht0803 hat geschrieben:das sind ja wahre Krimis mit dieser Schaltung. Wenn es tatsächlich gelänge, mit dem Buck Energie rauf oder runterzuschieben, wäre das natürlich der Clou.

Albrecht0803 hat geschrieben: Je nachdem, ob die Blei-Spannung ober- oder unterhalb der Buck-Ausgangsspannung ist, stellt sich die entsprechende Richtung von alleine ein. Das ist doch genau, was wir mit dem Li-Konzept erreichen wollen.


Ich habe ja früher schonmal einen bidirektionalen Wandler erwähnt, als Optimum oder Ziel.
Dass ich aber mal einen solchen Wandler als Basis haben würde, war nur eine Hoffnung. Das es aber ein 5 € Chinesenteil sein würde, und dazu noch ein so potentes, habe ich mir nicht träumen lassen.
Das ist ein echter Hammer, der Wünsche generiert.

Albrecht0803 hat geschrieben:Selbst wenn man den vorhandenen Wandler nicht zu dieser Arbeitsweise umstricken kann, würde es sich vielleicht lohnen, einen mit passenden Specs selbst zu designen?


Ich bin sicher, den umstricken zu können, aber ich bin nicht sicher, für wieviel Leistung.
Gesehen habe ich 10 Watt, einfach deswegen, weil die 12V Seite auf 1 A strombegrenzt war (mein Universalnetzteil).
Das Datenblatt gibt diesbezüglich auch nichts her.

Albrecht0803 hat geschrieben:Für meine Schaltung stellt das von Dir beobachtete Verhalten des Bucks im Moment kein Problem dar, da er definitiv nur im Transfermodus zur Bleibatterie hin eingeschaltet ist. Ein wenig weiter bin ich schon gekommen, die Mosfet-Strecke Li-seitig muß wohl noch etwas anders angesteuert werden.


Natürlich ist das kein Problem für deine Schaltung, aber dummerweise würde ein funktionierendes Teil all die Relais und Schalterlogik ersetzen, die du gerade mühselig gebaut hast. Sorry.
Aber der Spass und das Lernen, was du dabei hattest, ist auf keinen Fall verloren.

Ich kann leider nicht weiterforschen mit dem Ding, mein Ersatzwandler, den ich hatte, ist jetzt im Womo, auf "Diode Mode" geblockt. Läuft.

Natürlich habe ich sofort 3 weitere bestellt, damit ich mit dem Teil weiter arbeiten kann.

Also kann ich momentan nur Forensik an dem ausgemusterten machen.
Ich habe mir die Halbleiter angesehen, Typ nicht mehr drauf (abgewischt...), On-Widerstand 10 mOhm, 3,5 nf und 3,25 V im Gate.
Auf der 12 V Seite macht 10 mOhm bei 15 A schon 150 mV, bei 15 A sind das ca. 2,5 Watt plus Schalterverluste. Die 36 V Seite liegt um den Faktor 3 niedriger durch den kleineren Strom. Das ist jetzt nicht richtig gut, ich weiss ja auch, dass er etwas warm wird.

Ein IRF4110 hat nur 4 mOhm und ähnlich Gatedaten. Ich werde auf jeden Fall mal einen Tausch probieren.
Und im übrigen müsste man nur eine Spannungsregelung, genaue : Begrenzung) der Eingangsspannung (wie widersinnig...) ergänzen, dann wäre das Ding schon über die Spannung der Ausgangsspannung steuerbar. :D
Das wären ein paar Widerstände, und ein Transistor. Also eine hochkomplexe Änderung.... :D

Wenn man sicherstellt, dass die 36 Voltseite nicht abgeschaltet wird/ist (kein OVP), ginge das Ding sogar so wie es ist. Ohne jede Änderung.

Alles in allem halte ich es für möglich, dass ich dieses Tei für meine Anwendung ( bis 100 W, bis 10 A auf der 12 V Seite) zu einem autarken bidirektionalen Wandler machen kann.
Das wird jetzt sehr spannend.

Albrecht0803 am 16 Nov 2019 20:35:50

Also, das wäre keine Katastrophe, die vielen Relais zu entsorgen, wenn es diese andere Lösung gäbe. Wenn man das Grundprinzip dieser Schaltung versteht, sollte es kein großes Ding sein, so etwas für genau unsere Anwendung evtl. auch mit anderen Bauteilen zu entwerfen.

Da ich selbst nicht genug von der Materie verstehe, würde ich die Schaltung, wenn Du sie rekonstruieren kannst, einfach mal durch mein Simulationsprogramm nudeln.

Die Mosfet-Strecke auf der Li-Seite scheint jetzt zu funktionieren. Sie ist aber sehr empfindlich. Habe zwei der Pegelwandlertransistoren getötet, nur weil die Meßspitzen einen kleinen Kontakt zwischen Basis und Kollektor verursacht haben. Beim Rausschneiden des defekten Transistors kam es zu einem gewaltigen Lichtbogen, incl. Verschweißungen zwischen Draht und Zange. Die Kondensatoren des Boosters halten die Energie wohl recht lange nach dem Abschalten.

Nach der Restaurierung verhält sich die Schaltung exakt wie in der Simulation.

Morgen geht es weiter, mit aller Vorsicht natürlich.... Anschluß des Li-Akkus. Dann der Blei-Block.

  • Die neuesten 10 Themen
  •  
  • Die neuesten 10 Reiseberichte
  • Die neuesten 10 Stellplätze

Victron BMS 12-200 bzw LiFePo4 Anschlussplanung
Lifepo4 Umrüstung Tips
Alle Rechte vorbehalten ©2003 - 2018 AGB - Datenschutzerklaerung - Kontakt