CampingWagner
hubstuetzen

Sunlight T67 - Ersatz einer zweiten Aufbaubatt durch LiIon 1 ... 5, 6, 7, 8, 9, 10, 11


biauwe am 12 Mär 2020 11:30:04

George67 hat geschrieben:Was sagen eigentlich die Fachleute dazu, wenn ein Bleiblock IMMER voll ist, also garkeine halbzyklen macht ?


Aus der Praxis.
Seit über 6 Jahre läuft nun das Hybridsystem störungsfrei (1153 Nutzungstage).
Ein Bleiakku schützt vor einer UVP-Abschaltung im Wohnmobil.
Hier wurde schon öfter berichtet, dass die Abschaltung vom BMS des LiFePO4 das Womo "stromlos" macht.

Was macht dann ein aktives System, mit Wechselrichter, Solar und Ladegerät?

Anzeige vom Forum


fschuen am 12 Mär 2020 12:24:41

George67 hat geschrieben:Was sagen eigentlich die Fachleute dazu, wenn ein Bleiblock IMMER voll ist, also garkeine halbzyklen macht ?


Das ist sehr gut für den Akku. Allerdings ist das Argument, dass er überflüssig ist, wenn er wirklich immer voll ist, nicht ganz von der Hand zu weisen.

biauwe hat geschrieben:Ein Bleiakku schützt vor einer UVP-Abschaltung im Wohnmobil.
Hier wurde schon öfter berichtet, dass die Abschaltung vom BMS des LiFePO4 das Womo "stromlos" macht.


Das ist auch völlig logisch, und bei näherer Überlegung auch der Sinn einer Abschaltung. Dagegen hilft ein Zweitakku, das ist durchaus richtig - allerdings wirklich jede Form von Zweitakku, angefangen vom billigen (<20 Euro) Notakku aus vier 18650er LFP-Zellen mit rund 3 Ah. Alternativ lässt man das BMS einfach weg und verbaut passive Balancer - dadurch wird das System einfacher, billiger und zuverlässiger.

Gruss Manfred

Anzeige vom Forum

Hier findest Du vielleicht schon, was Du suchst: --->Link

George67 am 12 Mär 2020 19:13:06

Erstmal danke an alle.
George67 hat geschrieben:.....Was sagen eigentlich die Fachleute dazu, wenn ein Bleiblock IMMER voll ist, also garkeine halbzyklen macht ?


andwein hat geschrieben:Dann wird deine Bleibatterie nicht mehr als zyklische Versorgerbatterie eingesetzt sondern als "StandBy" Die Ladespannung könnte/sollte dann im Sinne einer höheren Lebenserwartung auf ca. 13,8V reduziert werden.
Gruß Andreas

Nach meinen Beobachtungen geht bei meinem Ducato (2019) die Spannung selten über 13,8 V. Wenn, dann eher von der Solaranlage als vom Motor.

pfeffersalz hat geschrieben:Dass die Bleibatterie überflüssig ist. Bau sie aus.

Na, so ganz ohne Funktion ist sie ja nicht. Sie ist etwa die Pufferbatterie, die hier gelegentlich empfohlen wird. Der LiIon Wandler macht max 12 A, darüber muss Blei helfen. Das kommt in Stromspitzen schon vor.
Langfristig, als Projekt, hast du Recht. Vielleicht gehe ich Richtung Startebatterie Blei + LiIon 36 V, wäre interessant.


biauwe hat geschrieben:Aus der Praxis.
Seit über 6 Jahre läuft nun das Hybridsystem störungsfrei (1153 Nutzungstage).
Ein Bleiakku schützt vor einer UVP-Abschaltung im Wohnmobil.

Ich weiss leider nicht, woraus dein Hybridsystem besteht, aber so etwa arbeitet meine Kombination auch.


Also, ich schone meine Blei WB weiter, und überlege mir ein Nachfolgekonzept.

btw, ich habe eine 6 Monats-Zusammenfassung ins Blog gestellt.

Anzeige vom Forum


andwein am 13 Mär 2020 10:41:28

George67 hat geschrieben:.....Nach meinen Beobachtungen geht bei meinem Ducato (2019) die Spannung selten über 13,8 V. Wenn, dann eher von der Solaranlage als vom Motor.

Wenn Ducato Bj 2019 und mit Euro 6d und AddBlue wäre das möglich, dann hat das Ding ein intelligentes Generatormanagement, dann sollte man über einen Ladebooster zur Spannungserhöhung nachdenken.
Wenn Ducato Bj 2019 und mit Euro 6 ohne AddBlue hat der Ducato ein Problem, die Lima müsste bei den jetztigen Temperaturen und auf den ersten 100 km so um 14,2V bringen.
Nur so phi mal Daumen, Gruß Andreas

George67 am 13 Mär 2020 17:11:06

andwein hat geschrieben:Wenn Ducato Bj 2019 und mit Euro 6d und AddBlue wäre das möglich, dann hat das Ding ein intelligentes Generatormanagement, dann sollte man über einen Ladebooster zur Spannungserhöhung nachdenken.

Nein, das ist kein Adblue. Zum Glück nicht, wie ich nachträglich erfahren habe.
Selbst mit hätte ich bei meinem LiIon Block aber keine Probleme und brauche keinen Ladebooster, weil mein Lademanagement die 14 Volt nicht braucht. Dat iss ja eh ein Wandler (von 12 auf 36 Volt).

andwein hat geschrieben:Wenn Ducato Bj 2019 und mit Euro 6 ohne AddBlue hat der Ducato ein Problem, die Lima müsste bei den jetztigen Temperaturen und auf den ersten 100 km so um 14,2V bringen.

So hätte ich das auch gesehen.
Hab das jetzt aber über ca 2000 km beobachtet, ich kann die Spannungsanzeige vom Fahrersitz aus sehen, dass ich meistens 13,8 bis 14 sehe, nie darüber. Kann sein, dass dass nach einer halben Strunde irgendwann kommt, aber gesehen hab ichs nicht. Ich habe immer gedacht, das liegt am Licht, was ich immer an habe.

Gerade eben hab ichs nochmal probiert, das sah es anders aus: Fahrzeug hat 3 Tage gestanden, Solar hat beide Batterien voll gemacht.
Hab meinen LiIon Block stillgelegt, Solar Sicherung gezogen, Spannung Starter steht auf 14,2 Volt.
Gestartet, und zack ! steigt Starterspannung auf 14,4 und darüber. Und das bleibt auch, wenn ich Licht ein und aus schalte.

Jetzt läuft seit einer Weile das Radio an der SB, ohne Solar, und wenn da 1 oder 2 Ah raus sind, probiere ichs nochmal.

andwein am 14 Mär 2020 11:28:36

George67 hat geschrieben:....Hab meinen LiIon Block stillgelegt, Solar Sicherung gezogen, Spannung Starter steht auf 14,2 Volt.
Gestartet, und zack ! steigt Starterspannung auf 14,4 und darüber. Und das bleibt auch, wenn ich Licht ein und aus schalte.

So sollte es im Original sein!! Wenn der Lithiumblock zugeschaltet wird und die Bordspannung dann auf 13,8V sinkt ist die Lima überlastet. Was hat der den für eine Lima?? 120A?
Gruß Andreas

George67 am 14 Mär 2020 11:52:01

George67 hat geschrieben:....Hab meinen LiIon Block stillgelegt, Solar Sicherung gezogen, Spannung Starter steht auf 14,2 Volt.
Gestartet, und zack ! steigt Starterspannung auf 14,4 und darüber. Und das bleibt auch, wenn ich Licht ein und aus schalte.


andwein hat geschrieben:So sollte es im Original sein!! Wenn der Lithiumblock zugeschaltet wird und die Bordspannung dann auf 13,8V sinkt ist die Lima überlastet. Was hat der den für eine Lima?? 120A?

Bitte denke aber daran, dass mein LiIonblock als Ladestrom max. 12,5 A zieht, das ist ja geregelter Wandlerbetrieb, kein parallel geschalteter Akku. Das ist gerade mal halb so viel, wie das Licht oder die Motorelektronik jeweils alleine zieht. Von Überlastung kann da keine Rede sein, egal welche Lima drin ist.
Btw, auch ein kleiner Vorteil meines Konzeptes..... :mrgreen:

Welche Lima drin ist weiss ich garnicht. Sunlight Serie. Wo schaut man das nach ?

andwein am 14 Mär 2020 16:55:02

George67 hat geschrieben: ...Das ist gerade mal halb so viel, wie das Licht oder die Motorelektronik jeweils alleine zieht. Von Überlastung kann da keine Rede sein, egal welche Lima drin ist. Welche Lima drin ist weiss ich garnicht. ?

Es war auch nur als Hinweis gedacht, als Antwort auf "selten über 13,8 V". Der Wert kam nicht von mir.
Gruß Andreas

George67 am 14 Mär 2020 19:02:04

andwein hat geschrieben:Es war auch nur als Hinweis gedacht, als Antwort auf "selten über 13,8 V". Der Wert kam nicht von mir.
Gruß Andreas

Der Wert kam von mir, aber Überlastung kanns nicht sein.

Neuer Versuch hat ergeben:

SB 12,5 V - hat 6 Stunden Radio betrieben. WB 12,8 V - Ruhespannung. Kein Solar, kein Li Block.
Motorstart, SB geht in Sekunden auf 14,4 - WB auf 14,2 und nimmt dabei knapp 10 A, die in gefühlten 5 min auf 5 A fallen. Den Strom der SB kenn ich nicht, der muss ordentlich sein, jedenfalls höher als der der WB.
Licht ein-aus macht keinen Unterschied, also war die Lima nicht an der Leistungsgrenze.

Alles so, wie zu erwarten war.

Damit bleibt ungeklärt, warum ich "nur 13,8 V" gesehen habe, werde ich halt mal wieder beim Fahren drauf achten müssen.

Btw - der Unterschied der beiden Batterien von 0,2 V ist der Weg der 10 A übers EBL..... soweit also zu dem Thema Widerstand auf der Stromweg übers Trennrelais und der Sicherungen. Die Spannung haben sich halb angeglichen als der Strom gefallen ist.

Albrecht0803 am 15 Mär 2020 17:37:30

Test der Schaltungserweiterung:

Gut, dass alles erstmal sukzessive mit Jumperkabeln in Betrieb ging. Wieder endlos viele Fehler bereinigt. Vergessene Lötverbindungen, fehlende Massenverbindung auf der HV-Seite des Trennverstärkers.

Das Schlimmste aber: habe die 40V-Seite über ein kleines Relais angeschlossen, um im ausgeschalteten Zustand die ganze Geschichte stromlos zu haben. Dieses Relais hat die Gestalt eines ICs, was mich dazu verführte, es in zwei Buchsenreihen zu “sockeln“. Dass diese Buchsenreihen nur sporadischen Kontakt mit den Relaisbeinchen vermittelten hat mich einen ganzen Arbeitstag gekostet, bis das als Ursache scheinbar völlig unerklärlicher Messwerte identifiziert war...

Jetzt ist soweit alles im Sollbereich und als nächstes wird der Arduino wieder aktiviert. Da der schonmal erfolgreich lief, sollten die gröbsten Hindernisse nun überwunden sein.

Für heute hab ich erst mal keinen Nerv mehr für weitere Abenteuer mit dem Lötkolben.

George67 am 15 Mär 2020 19:20:11

Dranbleiben!! :!:

Anzeige vom Forum


Albrecht0803 am 17 Mär 2020 11:47:13

George67 hat geschrieben:Dranbleiben!! :!:


Ja klar!

War leider wegen höllischer Zahnschmerzen verhindert. Natürlich am Wochenende. Der Besuch beim Dentisten meines Vertrauens endete am Montag mit dem Verlust eines bereits denkmalgeschützten, weil gekrönten, Backenzahns. Die Schmerzen sind weg, der Zahn indes auch.

Egal. Jetzt geht es wieder an die Schaltung.


Eine alternative Idee für eine zukünftige Variante hätte ich noch, was hältst Du davon?

Blei wird ganz rausgeschmissen. Die Ladezuleitung wird permanent mit dem Booster verbunden und dieser permanent mit dem Li-Block.
Gleichzeitig wird der Li-Block mit dem Buck und den Wohnraum-Verbrauchern verbunden, im Prinzip auch permanent. Damit bestünde zwischen der Lichtmaschine und den Verbrauchern keine direkte Verbindung mehr, alles läuft über den booster und den Buck.

Um das zu verwirklichen, müsste man allerdings bucks und booster höherer Belastbarkeit haben. Kann man die evtl. parallelschalten? Und wenn ja, wie erreicht man eine halbwegs zuverlässige Gleichverteilung der parallelen Ströme?

George67 am 19 Mär 2020 20:54:59

Albrecht0803 hat geschrieben:

Eine alternative Idee für eine zukünftige Variante hätte ich noch, was hältst Du davon?

Blei wird ganz rausgeschmissen. Die Ladezuleitung wird permanent mit dem Booster verbunden und dieser permanent mit dem Li-Block.

Albrecht0803 hat geschrieben:Gleichzeitig wird der Li-Block mit dem Buck und den Wohnraum-Verbrauchern verbunden, im Prinzip auch permanent. Damit bestünde zwischen der Lichtmaschine und den Verbrauchern keine direkte Verbindung mehr, alles läuft über den booster und den Buck.

Albrecht0803 hat geschrieben:Um das zu verwirklichen, müsste man allerdings bucks und booster höherer Belastbarkeit haben. Kann man die evtl. parallelschalten? Und wenn ja, wie erreicht man eine halbwegs zuverlässige Gleichverteilung der parallelen Ströme?

Gefühlt ganz ungewöhnlich.
Du hast beim Laden immer Wandlerverluste, beim Speisen des Womo noch einmal. Soweit genau wie jetzt.
Wandler müssen immer die volle Leistung machen. Nicht wie jetzt.
Und was sind die Vorteile ?

Albrecht0803 am 19 Mär 2020 22:28:18

Die Verluste beim Laden wären egal. Da ist die Bleibatterie auch nicht zimperlich. Die Buck-Verluste tun mehr weh, die schmälern den tatsächlichen Kapazitätsgewinn.

Warum dann das Ganze? Erstmal spart es eine Menge Gewicht. Außerdem dürften die Kosten der Li-Zellen im Vergleich zur verbreiteten LiFe(Y)Po-Technik spürbar geringer sein. Dem Nachteil des zu großen Spannungsbereichs beim Laden/Entladen begegnet man mit den Wandlern. Wahrscheinlich liegt die optimale Spannungslage des Li-Blocks so, daß man im entladenen Zustand grade auf eine mittlere Blei-Akkuspannung kommt, also so etwa 4s-Schaltung. (Bei leeren Li-Zellen, 12,8V, bzw. 3,2V/Zelle). Im vollen Zustand (4V/Zelle, insgesamt 16V) müsste der Buck von 16 auf die besagten 12,8V wandeln.

Einen Vorteil sehe ich noch darin, daß man die Umschaltung zwischen Lade- und Entladebetrieb nicht mehr braucht. Das ganze käme ohne die bei mir installierte Relais-Orgie aus. War nur eine Gedankenspielerei im Moment. Erst mal muß das aktuelle Konzept ordentlich laufen!

Die Jumperkabel des Tochterboards sind jetzt alle mit dem Hauptboard verdrahtet. Von diesem gehe ich wiederum mit Jumperkabeln auf den nicht eingesteckten Arduino, um Schritt für Schritt die Funktionsfähigkeit aller Mess- und Schaltreaktionen ins Leben zu rufen. Brauche mal ein paar Stunden ungestörter Konzentrationsfähigkeit, sonst geht da allzu schnell etwas schief...

George67 am 21 Mär 2020 16:32:45

Du sparst die Umschaltung, dafür deutlich leistungsfähigere Wandler mit höherem Leerlaufstrom. Mit 4s verlierst du im Li Akku die Vorteile der höheren Spannung -> niedrigerer Strom.
Du verlierst die Vorteile, dass unter null Grad Blei immer noch aktiv bleibt.

Klar, machen kann man alles. Gefühlt ist es weniger vorteilhaft, müsste man aber sehr detailliert analysieren.

George67 am 21 Mär 2020 16:35:24

Nur als Hinweis an alle Mitleser, ich habe in
--> Link
einen 24 V Aufbau erarbeitet, mit Forumshilfe, welches jetzt tatsächlich realisiert wird.
Details auch in meinem Blog.

Insofern interessant, weil es ala Stocki eine Variante ohne WB wird, SB bleibt in Blei.

George67 am 22 Mär 2020 11:23:58

Albrecht0803 hat geschrieben:
Eine alternative Idee für eine zukünftige Variante hätte ich noch, was hältst Du davon?


Eines fällt mir noch ein - meine aktuelle Lösung ist optimal in dem Sinne, dass man am Auto NICHTS ändert, sondern man schliesst 100% P&P an, nur 2 Drähte, nur 12 A, egal wie die Bleiumgebung aussieht.

Albrecht0803 am 22 Mär 2020 15:28:06

Naja fast. Einen Ausschalter braucht man schon noch, sonst ziehen die Wandler im Standby die Akkus leer.

Bin grade eifrig am Testen. Rauchwolken sind noch nicht aufgestiegen, aber die Strommessungen, die schon mal liefen, scheinen jetzt zu spinnen. Dafür zeigt die potentialentkoppelte Li-Spannungsmessung Ansätze richtiger Werte. Das sieht schon mal gut aus.

George67 am 22 Mär 2020 17:16:15

Albrecht0803 hat geschrieben:Naja fast. Einen Ausschalter braucht man schon noch, sonst ziehen die Wandler im Standby die Akkus leer.
.


Ähm.... Nö.
Der Schalter sitzt am Wandler, also im PC Gehäuse wo die Akkus drin sind. Der ehemalige Netzteil Schalter.
Und der Anschluss ist am EBL... als "Zusatzlader".

Also nur gesteckt. Tragbares Gerät. Hab ich ja schonmal sinniert, dass man das auch zur Überwinterung hineinstellen könnte.

Als Akku die Pedelec Blöcke, die im Winter nix tun, und nur ein Speisewandler ohne Laden.
Das könnte einige Akkus retten.

Und weiter viel Erfolg!

Albrecht0803 am 29 Mär 2020 00:19:28

Heute hat erstmals alles im Testaufbau funktioniert. Aber natürlich geht der Ehrgeiz mit einem durch...

Zur Statusdarstellung hatte ich mir statt des seriellen Monitors das e-Paper—Display in den Kopf gesetzt. Nach längeren Forschungen stellte sich heraus, daß sich dieses von einem Teensy-LC ansteuern läßt, von dem Arduino Nano hingegen partout nicht. Also habe ich die Steuerplatine für den Teensy ertüchtigt. Jumper-verdrahtete Tests liefen soweit erfolgreich. Da der Teensy auf 3,3V läuft, der Nano aber auf 5V, mußten einige Pegelshifter verbaut werden.

Leider sind die Pins auch komplett anders angeordnet, so daß eine aufwendige Neuverdrahtung der Steuerplatine anstand. Die ist jetzt vollzogen, aber noch ungetestet. Das Ding neu aufzubauen wäre wahrscheinlich auch eine gute Idee gewesen. So ist die Verkabelung stellenweise etwas wild geraten.

Wenn morgen die Steuerung wieder läuft, wird die Software zur Ansteuerung des E-papers in das Steuerprogramm portiert und ein schickes Display programmiert. Das hat als standalone-Testanwendung bereits geklappt, so dass von dieser Seite keine Überraschungen zu befürchten sind.

George67 am 29 Mär 2020 01:19:04

Das sieht ja richtig gut aus!
Aus Erfahrung kann ich sagen, dass die Probleme jetzt beginnen.... :D

rkopka am 29 Mär 2020 01:26:36

Albrecht0803 hat geschrieben:Zur Statusdarstellung hatte ich mir statt des seriellen Monitors das e-Paper—Display in den Kopf gesetzt.

Aber ist es nicht gerade bei den Werten interessant, schnelle Änderungen zu sehen ? e-Paper ist dafür nicht gerade ideal. Außer für die akkumulierten Werte, die sich nur selten ändern.
Zum Basteln habe ich mir auch 2 e-Paper Displays gekauft. Allerdings habe ich bisher noch keine "richtige" Aufgabe dafür gefunden. Fast alles, wo ich ein Display will, hat sich ändernde Werte oder eine GUI, die auch häufige und schnelle Änderungen erfordert. Ideal ist es z.B. für wechselnde Türschilder oder Preisauszeichnungen im Supermarkt (was ich nicht brauche).

RK

Albrecht0803 am 29 Mär 2020 09:06:04

Ja, schnell ist die Anzeige wirklich nicht. Hatte ursprünglich vorgehabt, sie für eine elektronische Flugzeuginstrumentierung einzusetzen. Dafür reicht es definitiv nicht.

Zur Fehlersuche bei de Entwicklung der LiIo-Stützbatterie auch nicht. Aber wenn es erstmal fehlerfrei läuft, ändern sich die Werte ja nicht mehr so schnell. Da könnte ich mir update-Raten von 5, 10, oder auch 30 Sekunden vorstellen. Was wirklich überzeugt, ist die gestochen scharfe schwarz auf weiß Darstellung ohne Hintergrundbeleuchtung. Das sieht wirklich aus, wie mit einer Schreibmaschine auf Papier getippt.

Werde in Kürze ein Foto davon reinstellen.

At Georg: Angstmachen gilt nicht! Wegen Corona hat man zwar Zeit, an der Fuhre zu werkeln, aber es soll jetzt doch zügig fertigwerden....

George67 am 29 Mär 2020 12:02:32

Albrecht0803 hat geschrieben:At Georg: Angstmachen gilt nicht! Wegen Corona hat man zwar Zeit, an der Fuhre zu werkeln, aber es soll jetzt doch zügig fertigwerden....

Hat nichts mit Angstmachen zu tun....

Ist eines der grundlegenden Probleme bei der Entwicklung.
Passiert, wenn man noch während der laufenden Entwicklung den Plan ändert... nicht aus Notwendigkeiten, sondern nur wegen neuer features. Man findet dann kein Ende.....
Das war früher mal das Hauptproblem bei Softwareentwicklung.

Und das ist auch genau der Grund dafür, warum mein aktuelles System so (einfach) ist, wie es ist. :mrgreen:

rkopka am 29 Mär 2020 12:21:28

George67 hat geschrieben:Ist eines der grundlegenden Probleme bei der Entwicklung.
Passiert, wenn man noch während der laufenden Entwicklung den Plan ändert... nicht aus Notwendigkeiten, sondern nur wegen neuer features. Man findet dann kein Ende.....
Das war früher mal das Hauptproblem bei Softwareentwicklung.

Kenne ich. Mein Wasserstop ist inzwischen nicht mehr ein einfacher Relaisersatz, sondern hat auch ein WLAN Interface für Messungen, Statistik und Handyschalten der Wasserpumpe...
Allerdings läßt sich das Minimumsystem immer noch compilieren. Aber das ist für mich Hobby, nicht Beruf oder kommerziell. Und ebenso wie viele ihr Womo ungeachtet des Preises und des Nutzens aufrüsten, passiert es bei meinen Basteleien auch. Dort kostet es aber nur Zeit, fast kein Geld.

RK

Albrecht0803 am 29 Mär 2020 17:42:09

Trotz wilder Verdrahtung: Die ursprüngliche Funktionalität ist noch immer i.O., inzwischen bereits getestet mit dem Teensy.

Nächster Schritt: die Bibliotheken und den Code zur Ansteuerung des e-Papers importieren. Und dann am Plan festhalten und das Ding fertigmachen, sonst wird das nie was!

Aber unabhängig davon und von den zwischenzeitlichen Rückschlägen: Spass hat es schließlich auch gemacht, gelernt hat man eine Menge und die grundlegende Idee von Georg, auf der das Ganze beruht, ist einfach gut.

George67 am 29 Mär 2020 21:03:17

Schauen wir Mal.
Während du der Fertigstellung und dem ersten Test entgegen gehst, baue ich gerade an der zweiten Anlage. Diesmal für 24 V.
Ich wollte das schon fertig haben, aber ich habe einen Mosfetschalter zwischengeschoben.

Der erste Versuch, als Designstudie, ist komplett schiefgegangen. Erst habe ich mich in den Daten der Mosfets verguckt.
0,02 Ohm ist nicht 2 mOhm, sondern 20. OK, das wäre noch gegangen, aber der Schalter aus drei Mosfetpaaren hatte 0,5 V Spannungsabfall bei 10 A.
Hat mich ne Menge Zeit gekostet herauszufinden was los war.
Es waren die Mosfets selbst, 75 mOhm statt 20 wie im Datenblatt. Ebayware...

Dann habe ich meine Bestände durchsucht, und bin fündig geworden.... ausgerechnet bei den BMS Platinen der zerlegten Pedelec Akkus.
4,5 mOhm, für eine P Mosfet ist das fair.

Jetzt habe ich einen Schalter, der bei 10 A mal gerade 20 mV Spannungsabfall hat. 200 mW Verlust bei 10 A. Braucht keine Kühlung, ist bidirektional. 3 Mosfetpaare.
Mit etwa 6 Paaren könnte man einen 50 A Schalter mit unter 5 W Verlust bauen. Das würde bei 24 V auch für einen Wandler reichen. Oder der bekommt ein Zwischenrelais, und der jetzige Schalter mit 3 Paaren spielt Hauptschalter.

Albrecht0803 am 31 Mär 2020 11:19:09

Zwischenstand:

die Ansteuerung der Arduino-5V-Relais über die Pegelwandler 3,3 auf 5V war unzuverlässig. Mußte die Pegelwandler wieder rausschmeißen und durch zwei stinknormale Transistoren ersetzen. Nebenbei wurde mal wieder ein neuer Mosfet-Schalter fällig, diesmal auf der Bleiseite. Hauptsache man ist beschäftigt..... Weiß der Kuckuck, was diese Dinger immer wieder tötet!

Jetzt kommen die Anschlüsse für das e-Paper dran. Dieses hat insgesamt 7 Ports, die über eine Siftleiste steckbar auf meiner Steuerplatine enden. Damit ist diese Platine gut voll, mit all den Nach- und Umrüstungen sind die Teile hinsichtlich der Verbindungsführung wenig optimal angeordnet.

George67 am 31 Mär 2020 12:23:34

Was die Schalter tötet ist Spannung Zwischen Gate und Source. Allenfalls Überspannung zwischen Source und Drain. Aber mit Strom wird's kaum gehen, das würde. Riechen.

Du brauchst meinen Schalter. Bei 10 A hatte ich Erwärmung. Um 4 Grad. Und der ist An der Ansteuerung sicher bis 100 V. Und dann kommt allenfalls ein Widerstand, nicht der Mosfet.
Hast du da P oder N ? Welche Type? Welche Schaltung?
Ich meine nur den Mosfet Teil.

George67 am 31 Mär 2020 16:01:11

Noch ein Bild.
Wohlgemerkt, eine Designstudie für Messungen.


Albrecht0803 am 31 Mär 2020 21:36:45

George67 hat geschrieben:...

Du brauchst meinen Schalter. Bei 10 A hatte ich Erwärmung. Um 4 Grad. Und der ist An der Ansteuerung sicher bis 100 V. Und dann kommt allenfalls ein Widerstand, nicht der Mosfet.
Hast du da P oder N ? Welche Type? Welche Schaltung?
Ich meine nur den Mosfet Teil.



Also ich habe einen Schalter in der 12V-Masseleitung mit N-Mosfets und einen weiteren in der 40V-Leitung zum Li-Block. Letzterer mit P-Mosfets. Die Gate-Spannung ist per Zenerdiode auf 10 oder 12V begrenzt, in beiden Fällen.

Es sind mir beide Schalter schon kaputtgegangen, insofern würde ich gerne eine robustere Konstruktion einsetzen, was auch einfach machbar wäre, weil ich die Dinger vorsorglich auf eigene Platinen ausgelagert habe. Anschluß per Klemmen auf der Hauptplatine.

Inzwischen ist die Verdrahtung zum Steckanschluss des e-Papers fertig. Tests und erste Softwareanpassungen ab morgen. Die Löterei kostet mich regelmäßig den letzten Nerv. Ewig entstehen Lötbrücken zwischen benachbarten Lötpunkten und da, wo die Drähte halten sollen fließt mal wieder nichts...

George67 am 01 Apr 2020 10:08:28

Ich sagte schon, dass du dir mit dem trennen der Masse Ärger einhandelst. Ich würde das umbauen.
ausserdem hast du mit dem Boost das gleiche, der trennt auch die Masse, wenn die Unterspannungsabschaltung kommt, glaube ich.
Du kannst die N-Fets auch in der Plusleitung nehmen, musst eben iergendwie die notwendige positivere Spannung potentialfrei erzeugen. oder aus den 36 Volt entnehmen ?
Nachdem ich den P-Schalte jetzt hinbekommen habe, mache ich allses mit denen.
Ich mach dir den Plan, wie ich ansteuere.

George67 am 02 Apr 2020 17:56:48

Der 24 V Wandler läuft.
Hat mich einen Buck gekostet. Ist schon erstaunlich.
Ein Wandler, der eine 12 V Fernlicht birne , in Einstellung 24 V und ohne Strombegrenzung, so schnell abschiesst, das man die Lampe nur kurz anglimmen sieht.
Und verabschiedet sich kampflos, nur weil die 45 V am Eingang, bei Strombegrenzung 0,5 A, verpolt ist.... :mrgreen:

Albrecht0803 am 02 Apr 2020 23:15:22

Ja, ja, 45 Volt verpolt ist schon ein Wort! Warum 45V, sollten das nicht 24 sein?

Ich kämpfe weiter, jetzt mit der Software. Hatte das tolle Erlebnis, daß die Steuersoftware alleine und auch die E-Paper-Software für sich erstmal liefen. Zusammen aber nicht. Da schien die E-Paper-Software die Steuersoftware direkt abzuschiessen. Nach länglicher Analyse zeigte sich, daß die e-paper Software den ganzen Prozessor ausser Gefecht setzte, aber nur, wenn gleichzeitig die Steuersoftware drankompiliert wurde.

Klassischer Fall von Speicherbereichsverletzung. Konnte die sündigen Stellen (Concatenation von Texten in Character-Variablen (!)) dann identifizieren und soweit bereinigen. Kostete einen vollen Arbeitstag und die eigentliche Aufgabe, die Programmteile erneut zusammenzuführen liegt noch vor mir...

Dass dieser Teil einzeln lief, war wohl ein glücklicher Zufall. Da wurde wohl nichts lebenswichtiges überschrieben. Wahrscheinlich würde das Programm nach dem debuggen auch auf dem Nano laufen, was ja ebenfalls nicht geklappt hatte. Das habe ich allerdings nicht probiert und ich werde die Platine deswegen auch nicht zurückrüsten.

Immerhin weitergekommen, wenn auch mal wieder im Schneckentempo.
Aber das wird schon!

George67 am 03 Apr 2020 08:01:39

Durchhalten.
Hast du Probleme mit löten?

Albrecht0803 am 03 Apr 2020 13:00:01

Die Display-Software ist im Entwurfsmodus fertig, siehe Foto. Im Moment werden Dummy-Werte ausgegeben, die eigentliche Steuersoftware kommt noch dazu.

Werde die Anzeige wohl nur einmal pro Minute automatisch updaten, aber einen zusätzlichen Taster zum manuellen Anfordern eines Refreshs spendieren. So langsam nähert sich die Angelegenheit dem beabsichtigten Zielzustand.



Albrecht0803 am 03 Apr 2020 20:44:45

Nachtrag:

Die beiden Programmteile sind jetzt vereinigt. Alles läuft immer noch. Es sind noch kosmetische Änderungen vorzunehmen, Taster-Refresh, Timing über Millis, statt delays etc. Und Feinkalibrierung der Meßsensoren.

Nächster Schritt: die Aufrüstung des Li-Blocks auf 10s10p, statt wie zum Test 10s1p. Gehäuseeinbau, mechanische Sicherung der gesteckten Tochterplatinen, damit die sich im Fahrbetrieb nicht losrappeln können.

Und dann: Praktische Erprobung auf Reisen! Hoffentlich überwinden wir die Corona-Zeiten gesund und rasch...

George67 am 04 Apr 2020 10:01:26

Albrecht0803 hat geschrieben:Nachtrag:

Die beiden Programmteile sind jetzt vereinigt. Alles läuft immer noch. Es sind noch kosmetische Änderungen vorzunehmen, Taster-Refresh, Timing über Millis, statt delays etc. Und Feinkalibrierung der Meßsensoren.

Das hört sich mal gut an.

Albrecht0803 hat geschrieben:Nächster Schritt: die Aufrüstung des Li-Blocks auf 10s10p, statt wie zum Test 10s1p. Gehäuseeinbau, mechanische Sicherung der gesteckten Tochterplatinen, damit die sich im Fahrbetrieb nicht losrappeln können.

Heisst - jetzt kommt endlich viel Arbeit, die Spass macht und spannend ist.

Albrecht0803 hat geschrieben:Und dann: Praktische Erprobung auf Reisen! Hoffentlich überwinden wir die Corona-Zeiten gesund und rasch...

Dann los ! :D

Albrecht0803 am 06 Apr 2020 00:05:13

Frust!

Auf der Suche nach einem Fehler der Temperaturmessung geriet der Schraubenzieher zwischen zwei Lötpunkte, die das gar nicht mochten:

Funkenflug, Rauch, der zu recht beliebte Geruch gegrillter Elektronik....

Erste Schadensbilanz: Der Teensy ist hinüber. Das E-Paper auch. Die Spannungsmessung mit einem Ersatz-Prozessor zeigt auch nichts Vernünftiges mehr an, also wahrscheinlich weitere Schäden.

Immerhin haben die Mosfet-Schalter ausnahmsweise diesmal überlebt. Eigentlich ist das der Zeitpunkt, alle die aufgelaufenen Ideen zur Verbesserung durch radikalen Neu-Aufbau umzusetzen. Beginnend mit der Verlagerung des 12V-Mosfet-Schalters von der Masse- auf das 12-Potential. Damit entfiele auch die Krücke mit dem Trennverstärker zur 40V-Spannungsmessung.

Neustrukturierung der Steuerplatine, evtl. Rückkehr zum Arduino-Nano, wodurch das System wieder einheitlich auf 5V-Basis läuft.

Ersatzteile sind schon bestellt, ich werde zumindest die Steuerplatine neu aufsetzen. Die Relaisplatine läßt sich vermutlich umstricken, auch wenn es hinterher auf der Lötseite sicherlich wie nach einem Meteoreinschlag aussehen wird...

George67 am 06 Apr 2020 09:10:21

Ich glaube, langsam hast du den pechvogel Preis verdient.

Ich werde dir mal zeitnah den Schaltplan meines P-Mos Schalters einstellen, wie ich das machen würde bzw. gemacht habe. Muss nur mal schnell nen Schaltplan in target üben.

Albrecht0803 am 06 Apr 2020 18:55:52

Bin bereits an der Restrukturierung. Die Masseleitungen werden nicht mehr unterbrochen, auf der 12V-Seite kommt eine Kopie meines p-Mosfet-Schalters in die Plus-Leitung. Die Relaisplatine ist schon entsprechend modifiziert.

Die Steuerplatine mit dem Arduino baue ich neu. Die vereinfacht sich nochmal deutlich. Werde versuchen, das e-Paper am Nano zum Laufen zu kriegen, was nochmal eine Vereinfachung bedeutet.

Am Ende wird das Gerät besser sein als der Vorgänger, bei dem sich doch eine Menge Kompromisse und Umständlichkeiten angehäuft hatten.

Die Ersatzteile sind bereits auf dem Versandweg, denke noch vor Ostern den alten Funktionsstand wieder erreichen zu können.

Albrecht0803 am 07 Apr 2020 22:56:19

Die neuen Displays (vorsichtshalber gleich mal 2 bestellt) sind eingetroffen. Beim Test mit dem letzten verbliebenen Teensy ist es mir gelungen, diesen auch noch zu töten, auf ganz fiese Art:

Das e-Paper läßt sich in 5V oder 3,3V Systemen gleichermassen einsetzen. Es steuert seine Logikpegel entsprechend der Vcc-Eingangsspannung, die man anlegt. Der Teensy-LC ist nicht 5V-tolerant. Der Versuch, das e-Paper statt auf dem 3,3V Level mit 5V zu versorgen, hat den armen Teensy ganz ohne Funkenflug und unspektakulär zerstört....

Dann halt das ganze Ding nochmal am altbewährten Nano aus der Vorratskiste verdrahtet, und siehe da: Nach Beseitigung des Speicherkonflikts funktioniert der auch mit dem Display.

Die Steuerplatine ist im Aufbau, der 12V-p-Kanal-Mosfetschalter ist fertig (3x2 IRF4905 Transistoren). Schätze, daß bis morgen Abend das Ding wieder laufen könnte.

George67 am 08 Apr 2020 09:38:19

Albrecht0803 hat geschrieben:......, der 12V-p-Kanal-Mosfetschalter ist fertig (3x2 IRF4905 Transistoren).

Der 4905 war mal meine Empfehlung - ein Irrtum, weil ich nicht richtig lesen konnte. Der On-Widerstand ist zu gross, und zusätzlich habe ich auch noch gefälschte - weil schlechte -bekommen. (75 mOhm).

Ich habe in alten BMS Platinen BS3002 gefunden, 4,6 mOhm, und 100P06 5,6 mOhm. Das wäre viel besser. Und wenn das nicht reicht, sollte man trotz der unbequemeren Ansteuerung N-Fets nehmen. Miss auf jeden Fall nach, welchen Spannungsabfall dein Schalter hat.

George67 am 08 Apr 2020 10:51:46

Mein Schalter, 3 Paare, mit den 4905 hat 50 mOhm, der mit den BS3002 hat nur 3 mOhm.

Du musst bei P Schalter an 12 V darauf achten, dass die Gates genug Spannungsdifferenz bekommen, damit die in die Sättigung gehen. Das kann bei alten Typen, die 8 V brauchen, eng werden.
Schaltplan ist fertig für dich, wie ich das machen würde, ist aber für 36 V ausgelegt. Muss noch die Werte für 12 V machen, dann bekommst du es.

Der Nano hat doch 3,3 V, können die Ausgänge pull Up oder nur pull down?
Ich hab die Pegelwandlung von 3,3 mit pullup schon dabei.

rkopka am 08 Apr 2020 11:09:27

George67 hat geschrieben:Der Nano hat doch 3,3 V, können die Ausgänge pull Up oder nur pull down?
Ich hab die Pegelwandlung von 3,3 mit pullup schon dabei.

Der Nano ist ein 5V Typ. 3,3V kann er nur eingeschränkt (Takt) und die HW ist nicht dafür vorgesehen. Die internen 3,3V sind auch nur schwach belastbar. Mini und Pro mini gibts in beiden Versionen.

RK


  • Die neuesten 10 Themen
  •  
  • Die neuesten 10 Reiseberichte
  • Die neuesten 10 Stellplätze

Thermoschalter für Winston-Zellen
Billigst-LiFePO4 aus China
Alle Rechte vorbehalten ©2003 - 2020 AGB - Datenschutzerklaerung - Kontakt