aqua
anhaengerkupplung

Sunlight T67 - Ersatz einer zweiten Aufbaubatt durch LiIon 1 ... 6, 7, 8, 9, 10, 11


Albrecht0803 am 08 Apr 2020 12:41:34

Der Nano läuft standardmäßig mit 5V, kann aber eine 3,3V-Versorgung ausgeben. Auch läßt sich die Referenzspannung der AD-Wandler auf 3,3V einstellen. Hatte die bisherige Lösung mit 3,3V Referenz betrieben, sowohl mit dem Nano wie auch mit dem Teensy. Werde bei der Rückrüstung auf den Nano aber einheitlich auf 5 V gehen und den Nano über den 5V Pin mit einem Pololu 5V Buck versorgen. Der liefert dann auch gleich die externe 5V-Referenz für die AD-Wandler.

Die BS3002 haben ja sensationelle Daten. Habe mir grade eine größere Anzahl davon bestellt, bei Mouser. Der modulare Aufbau mit den separaten Mosfet-Platinen macht einen späteren Austausch der 4905er gegen die 3002er zum Kinderspiel. Bis die neuen Transistoren da sind, kann ich mit den vorhandenen schonmal weitermachen. Georg, bin natürlich scharf auf Deinen Schaltplan, gerne auch mit den Werten für die 36V-Seite!

Lesen bildet: Die Spannungsteiler der bisherigen Lösungen waren wohl zu hochohmig. Der Arduino braucht etwas in der Größenordnung von 10k, sonst rauschen die Messwerte. Das wird beim Neuaufbau gleich miterledigt. Das Rauschen hatte ich beobachtet und per Mittelwertbildung in einer Schleife etwas gemildert.

Diese Spannungsteiler greifen die Spannung direkt an den Pluspolen der Akkus ab und würden diese mit ihrem Ruhestrom permanent, also auch in ausgeschaltetem Zustand belasten. Deshalb werden sie über ein Reed-Relais nur dann aufgeschaltet, wenn das System in Betrieb ist. Im Aus-Zustand sind sie von den Akkupolen getrennt.


George67 am 08 Apr 2020 13:38:19

Mess mal bitte den Spannungshub der Digitalausgänge. Kann sein, dass die nur 3,3 V haben, auch wenn der prozessor auf 5 V läuft.

Was zahlst du für den BS 3002 ? Ich habe noch einen brauchbaren PMos gefunden, 100P06. Aber trotzdem, N-Mosfets gibts mit kleineren RDS on, und auch für höhere Spannungen wie 100 V.

Rauschen, hast du eine kleine Kapazität parallel zum Arduino eingang ? 100n oder so, sollte das rauschen beseitigen. Niederohmige Spannungsteiler sind schlecht.

Albrecht0803 am 08 Apr 2020 14:27:09

Die Bs3002 kosten 3,22+ Mwst pro Stück.

Kann gerne mal den Spannungshub der Nanos messen, bin aber sicher, dass da alles auf 5 V läuft. Der Nano ist einfach der Uno auf kleinerer Platine.

Hochohmige Spannungsteiler haben laut Lesestoff Schwierigkeiten, die internen Kapazitäten des im Multiplex-Verfahren auf die verschiedenen A-Eingänge durchgeschalteten AD-Wandlers schnell genug zu füllen. Daher die Empfehlung irgendwo in der Gegend von 10k zu arbeiten. Ich hatte bisher schon die Grenze von 1M angekratzt, was sicherlich zu hoch war. Zusätzliche Kapazitäten, die Du vorschlägst, helfen natürlich dabei, die internen Kapazitäten schnell zu füllen, das geht sicherlich auch. Die Eingangskapazität des AD-Wandlers wird mit 14pF angegeben, da sind 100n ein ausreichendes Polster.

Anzeige vom Forum


George67 am 08 Apr 2020 15:26:25

Der Kondensator muss natürlich an jedem Spannungteiler vorhanden sein, vor dem multiplexer. Und du musst über die Leitungsführung nachdenken, Stichwort getrennte Analogmasse.

George67 am 08 Apr 2020 20:27:54

So, ein erster Versuch.


Albrecht0803 am 09 Apr 2020 06:48:23

Danke, Georg.

Meine Schaltung ist ähnlich.

Steuertransistor BC337.
R1 und R2: 100k.
R3: 75k.
R4: nicht Bestandteil des Mosfet-Moduls. Wenn direkt auf 12V+ geschaltet wird, habe ich 1M an der Basis auf der 40V-Seite.
C1: Bei mir nicht vorhanden. (Bis jetzt).
D1: 10V-Z-Diode.

George67 am 09 Apr 2020 16:44:52

Albrecht0803 hat geschrieben:Danke, Georg.

Meine Schaltung ist ähnlich.

Steuertransistor BC337.

nur 45 V Uce. Knapp.
Der BST 52 hat 100 V und 1 A. Ok, vollkommen überdimensioniert, aber dafür robust.
Und ist ein Darlington, das erhöht die Schaltschwelle auf 1 V an der Basis. Bessere Störsicherheit.

Albrecht0803 hat geschrieben:R1 und R2: 100k.

OK für 36 V, ber nicht für 12V.
Wirkt wie ein Spannungsteiler für den Spannungshub. Du musst für 11 V rechnen, wo es noch gehen soll, die Hälfte ist 5,5 V.
Geht beim BS3002 nicht, der braucht über 8V am Gate, wenn ich mich recht erinnere.
Also 220 K zu 10 K, das wäre meine Wahl für einen 12 V Schalter. Gibt dann zwar höheren Steuerstrom bei 14 V, aber das ist ja bei 0,5 mA wohl egal.

Albrecht0803 hat geschrieben:
R3: 75k.

Ich liebe das niederohmiger, wegen Störsicherheit. 75 K bei 0,5 oder 1 V sind nur noch 15 mue-A, das ist mir zu wenig.

Albrecht0803 hat geschrieben:R4: nicht Bestandteil des Mosfet-Moduls. Wenn direkt auf 12V+ geschaltet wird, habe ich 1M an der Basis auf der 40V-Seite.

Würde ich nicht machen, so hast du eine offene Basis auf der Leitung. Nicht kurzschlussfest nach 12 V.
Aber ich verstehe jetzt deine 75 Kohm als R3. Kannst du die 1 Mohm nicht kleiner machen ?
Bei 5 Volt ist r3/R4 als 1:1 ok. Bei 3,3 V müsste man etwas nachhelfen, deswegen habe ich gefragt.

Albrecht0803 hat geschrieben:C1: Bei mir nicht vorhanden. (Bis jetzt).


22 bis 100 n, ergibt eine Zeitkonstante von ca 5 bis 22 ms, musst du beim Abschalten berücksichtigen. Ist aber so ziemlich störsicher.

Albrecht0803 hat geschrieben:D1: 10V-Z-Diode.

Zwischen 8V und 12V ist ok, beim BS3002 mit den 8V aufpassen und testen, ob das reicht.
Fet soll ordenlich in die Sättigung durchgesteuert werden.

Albrecht0803 am 09 Apr 2020 21:43:04

Moin Georg und Danke für die Erläuterungen.

Meine Daten stammen von der 40-V-Seite, sie haben dort funktioniert. Aktuell verbaut sind die IRF 4905-Mosfets, die Bs3002-Typen haben sich gerade erst in Texas auf den Weg gemacht.

Den Steuertransistor werde ich noch ändern (habe aktuell keinen passenden im Regal) und auch die Widerstände auf der 12V-Seiite. Die habe ich schlicht 1:1 von der 40V-Seite übernommen. Auf der 40V-Seite werkelt ein Mosfet-Paar, auf der 12V-Seite sind es drei parallele Paare.

Die neue Steuerplatine ist fertig. Morgen geht es ganz behutsam ans Testen, vorher noch die Mosfet-Schalter überarbeiten.

Albrecht0803 am 10 Apr 2020 13:51:49

Nachtrag zur hochhmigen 1M Ansteuerung des Transistors:

Meine ursprüngliche Konfiguration sollte mit einem einzigen + Signal sowohl den Mosfet-Schalter der 40V-Seite, wie auch den n-Kanal-Schalter der Masseleitung auf der 12V-Seite ansteuern. Die 12-Seite brauchte damit gar keinen Steuertransistor. Aber die Rückwirkung der Basis-Emitterstrecke des 40V-Steuertransistor schaltete die 12V-Seite durch. Das hörte erst auf, durch den 75k-Widerstand und einem entsprechend erhöhten Widerstand (1M) in der Basis-Zuleitung.....

Die Voraussetzungen sind jetzt günstiger, nachdem beide Mos-Fet-Schalter in den jeweiligen Plus-Leitungen liegen. Eigentlich braucht man auch keinen Steuertransistor mehr, wenn man die Gates zum Einschalten Richtung Masse zieht. Da ich aber weitere Teile der Elektronik (Spannungsteiler, Arduino) mit einem einzigen Plus-Signal schalten will, habe ich den Steuertransistor auf beiden Seiten belassen.

George67 am 10 Apr 2020 14:45:42

Beide Leitungen mit einem pulldown geht auch nicht. Dann bleibt die 36 v an.

andwein am 10 Apr 2020 15:22:40

George67 hat geschrieben:Beide Leitungen mit einem pulldown geht auch nicht. Dann bleibt die 36 v an.

Und eine Entkoppelung durch eine TTL Logik????
Nur ne Frage, Andreas

George67 am 10 Apr 2020 15:46:56

andwein hat geschrieben:Nur ne Frage, Andreas

Das ist ein Trickschaltung, es ist eine Stromsteuerung. Bezieht sich auf dn Spannungslevel, der geschaltet wird, dir Steuerspannung wird mit einem open Collector nach Masse erzeugt.
Koppelt man beide Signale, ist der 12 V schon "Masse" für den 36 V.
Deswegen brauchen beide einen eigenen Transistor, der nach Masse zieht - weil beide Signale für aus auf ihren level "hochgehen" müssen.

George67 am 10 Apr 2020 15:59:26

Vielleicht sollte ich mal erwähnen, wie man so eine Ansteuerung einer Mosfetgruppe "richtig" macht : APV1122.

Da ist dann die Differenzspannung egal.

Albrecht0803 am 10 Apr 2020 22:34:56

Am 12V Mosfet-Schalter verzweifle ich noch!

Habe das Ding aufgebaut, die Widerstände soweit geändert und es schaltete auch durch, wie erwartet. Aus Neugier dann die Spannung über der Zenerdiode gemessen:

Die scheint völlig wirkungslos zu sein! Die Spannung war entweder Null (Steuertransistor gesperrt) oder praktisch identisch mit der Netzteilspannung, die den Bleiakku simuliert.

Die Zenerdiode mühsam ausgelötet und an einer Versuchsstrecke mit 5k Widerstand bei veränderlicher Spannung gemessen. Da hat sie als 10V-Typ bei ca. 9,5V reproduzierbar angefangen zu leiten und die Spannung auf diesem Level gehalten. Sie ist somit nicht defekt.

Inzwischen ist durch allerlei rumprobieren der Steuertransistor und/oder einige der Mosfets hinüber. Zumindest ändert sich die gemessene Gate-Spannung kaum noch (liegt bei 0,2V). Trotzdem schaltet die Mosfet-Strecke scheinbar durch, allerdings als einzige Last das Multimeter dran.

Verstehen tu ich diesen Zauber allerdings überhaupt nicht mehr. Werde den Schalter morgen nochmal neu aufbauen und stückweise in Betrieb nehmen. Die aktuelle Platine sieht aus wie eine Tropfsteinhöhle und fast alle Löcher sind inzwischen gut mit Lötzinn geflutet...

George67 am 11 Apr 2020 07:06:28

Ist mir ein Rätsel.
Nimm mehr Last, nicht nur das Multi. 20 mA reicht.
Hast du wirklich die richtige Schaltung?
Die beiden mittleren Anschlüsse dürfen nicht miteinander verbunden sein, dazwischen wird geschaltet. Verbunden ist Pin 1 mit 1 und 3 mit 3.
Wenn man auf ein Paar schaut.

George67 am 11 Apr 2020 07:37:37

Kühlbleche dürfen nicht miteinander verbunden sein, dazwischeni liegt die geschaltete Spannung.

George67 am 11 Apr 2020 10:15:41

Irgendwas läuft bei dir falsch.
Es grenzt an unmöglich, in der Schaltung von mir einen Mosfet zu zerstören, ausser durch: Überspannung, Überstrom, oder allgemein thermisch.
hast du eine lötstation mit Transformatortrennung ?
hast du einen tester für mosfets?
hast du die Mosfets richtig geschaltet ?
Nur Multimeter als last ergibt interessante Messfehler. Ist die die Arbeitsweise der Antiparallelschaltung, mit ihrer Ansteuerung, klar? Speziell die Spannungspegel des Punktes, wo die mosfets verbunden sind ?
Was ich überhaubt nicht verstehen kann, ist dass du den Transistor kaputtkriegst. ausser durch Überstrom an der basis, durch deinen fehlenden Widerstand. nichtmal wenn der mosfet kaputt wäre, weil der Kollektorwiderstand den strom begrenzt...
kannst du Fotos machen, wo man deine Schaltung erkennen kann ?
Ich habe bei der ganzen bastelei, inclusive Ablöten der D2Paks, nach über 30 Stück keinen einzigen Defekt bisher.

Albrecht0803 am 11 Apr 2020 10:23:44

Also die Schaltung ist schon richtig, alles so verdrahtet, wie Du beschrieben hast. Und es hat ja auch soweit funktioniert.

Auf der 12V-Seite ist die Zenerdiode eigentlich überflüssig, für die 4905er gilt ein Max-Rating von +- 20V Gate-Spannung. Da kann nichts passieren. Wie es auf der 36V-Seite aktuell aussieht habe ich noch nicht gemessen.

Insgesamt scheint es mir einfacher, sowohl auf die Steuertransistoren als auch auf die Zenerdioden zu verzichten. Die Steuerspannung wird per Spannungsteiler R1/R2 jeweils fest eingestellt und bei Bedarf zum Einschalten der Spannungsteiler gegen Masse geschaltet. Dann kann auch nichts mehr passieren. Der Schalter gegen Masse kann natürlich auch wieder ein Steuertransistor sein, muß aber nicht unbedingt.

Ok, die Mosfets scheinen noch i.O. zu sein. Beim Entnehmen des Schalters aus seinen Schraubklemmanschüssen hatte ich einmal das Netzteil noch aktiv dran. Mit dem Schraubenzieher gab es dann eindrucksvolle Funken. Das erklärt wahrscheinlich den Defekt.

Baue den Schalter neu auf und schicke heute Nachmittag aussagefähige Fotos von dem Teil.

Albrecht0803 am 11 Apr 2020 10:31:07

Die Lötstation hat wahrscheinlich keinen Trenntrafo. Ist ein relativ billiges Teil mit digitaler Temperaturregelung und Heißluftfön. Thermisch tut sie was sie soll.

Einen Mosfet-tester habe ich nicht. Der Anschluss an einen normalen Tester sagt, dass es sich um einen Pnp-Typen handelt, ein n-Kanal Mosfet wird dagegen als npn identifiziert.

George67 am 11 Apr 2020 10:55:37

Die zenerdioden sind das, was den fet unzerstörbar macht, weil sie die gatespannung begrenzen, für beide Polaritäten. Das ist die empfindliche Stelle der fets. Lass die ja nicht weg. Und bei richtiger Auslegung des Spannungsteiler sorgen sie für eine gleichmäßige Steuerspannung unabhängig von der Betrieb Spannung. Du musst daran denken, das diese Trickschaltung die Steuerspannung aus der geschalteten Spannung gewinnt. Bei zu kleiner Spannung geht's nicht mehr, schlimmer, die fets ziehen dann Leistung.

Die 20 V sind Maximum Ratings, davon solltest du Abstand halten. Sättigungsspannung plus 2 oder 3 Volt ist optimal. Bs3002 braucht über 8 V, glaube ich, der 4905 geht auch niedriger, z.B.
Hast du Dioden an den Relais? Die liefern sonst Spannungsspitzen.
Diese Trickschaltung ist wirklich Tricky, fast jedes Bauteil hat 2 oder mehr Aufgaben. Lass nix davon weg!
Und sag mir nochmal deine Auslegung. Und mess Mal die Spannung an den Mosfet Gates im Ein Zustand. Das muss gleich der Betriebsspannung sein.

George67 am 11 Apr 2020 12:01:01

Messe gerade, dass die bs3002 nur 5 v brauchen. Muss nochmal ins Datenblatt schauen.

Albrecht0803 am 11 Apr 2020 16:13:33

So, nun ist das Ding neu aufgebaut. Eigentlich alles wie gestern. Mit dem Unterschied, daß es jetzt einschließlich der Spannungsbegrenzung durch die Zenerdiode funktioniert...

An den Relais sind Dioden. R1 ist 220k, R210k, entsprechend Deinem Vorschlag. Basis-Emitter-Widerstand des Steuertransisors 4k7. Angsteuert wird die Basis per Vorwiderstand von 7k5 direkt auf plus 12V.

Was meinst Du mit der Gatespannung? Die wird doch von der Zenerdiode eingestellt.

Mein chinesischer Transistortester war gar nicht so übel. Er hat die Fets doch klar erkannt, lieferte jedoch unrealistische hohe Werte für Rds.
Typische Anzeige 0,4Ohm. Das kann hoffentlich nicht stimmen.

Mitten in der Messkampagne zur Durchsicht der Mosfets hat er dann einfach den Geist aufgegeben. Aufladen hat auch nichts mehr genützt, ab in die Tonne.

Mit den 8V bei den bs3002 liegst Du schon richtig. Es gibt im Datenblatt ein Diagramm, das man so interpretieren kann, dass alles unter 8V schlechter ist. In den Tabellen habe ich allerdings nichts dazu gefunden.

Hier ein paar Fotos. Zur Schaltungskontrolle wohl weniger geeignet, aber da es funktioniert, brauchen wir es hoffentlich nicht mehr.
Die neue Steuerplatine liegt noch daneben, ich eollte sie bei den Versuchen mit den Mosfets nicht auch gleich wieder himmeln.

Man kann den Schalter erkennen, mit dem die Mosfets angesteuert werden. Außerdem den Taster, mit dem man einen Refresh des e-paper Displays auslöst.

Werde jetzt abschnittsweise die Steuerplatine per Kabel mit den zugehörigen Buchsenleisten der Hauptplatine verbinden und an den Anschlüssen des Arduino messe, ob alles richtig ankommt. Erstmal ohne den Prozessor, wenn alles paßt, dann mit.

Letzte Aktion ist dann der Anschluß des Displays.

Albrecht0803 am 11 Apr 2020 18:31:21




George67 am 12 Apr 2020 12:12:54

Da hast du dir richtig Arbeit gemacht, das sieht richtig gut aus. Speziel die Verdrahtung der Relais.
Ich sehe Module als Mosfetschalter. Prima.
Du setzt die Mosfets ohne Kühlblech.... ich bin dazu zu ängstlich. Ich grüble noch immer über etwas Kühlung.
Die ModulPlatinen sind Arduino ? :D

Albrecht0803 am 12 Apr 2020 14:48:14

Kühlung braucht es im Moment noch nicht, da zum Test nur mit 10s1p die Ströme noch sehr klein sind. Ausserdem werden die Mosfets ja noch durch die Bs3002er ersetzt.

Kühlbleche liegen schon zuhauf herum, wahrscheinlich passen am Ende alle nicht....

Bei der schrittweisen Inbetriebnahme stellte sich, neben den üblichen kleineren Verdrahtungsfehlern, heraus, daß beide Stromsensoren aufgrund des vorausgegangenen Funkenflugs beschädigt waren. Das ist jetzt behoben. Es steht noch der Test der Hochvoltseite und deren Spannungsteiler Richtung Arduino aus, dann kann der Prozessor wieder drauf. Sollte wohl heute zu schaffen sein.

George67 am 12 Apr 2020 17:12:55

Daran versuche ich mich gerade:



Ich versuche das unter 50 mal 50 zu bringen, dann passen 6 auf eine Europakarte.

George67 am 13 Apr 2020 21:31:56

Was für eine Steckverbindung würdest du an eine solche Platine dran machen ? Flachstecker?
Ich hab jetzt übrigens beide Seiten belegt, 6 Paare....

Albrecht0803 am 14 Apr 2020 23:57:06

Schicke Platine, aber SMDs selbst löten? Mit den Transistoren hoffe ich es zu schaffen, aber die kleineren Teile würde ich nie und nimmer heil auf die Platine kriegen.

Als zweipolige Steckverbindung nehme ich gerne XT60-Stecker aus dem Modellbau. Die 60 stehen für 60A Strombelastung. Man kann sie nicht aus Versehen verpolt anschließen. Für die 60-er findet man gelegentlich Varianten, bei denen eine der beiden Seiten mit Schrauben z.B. Auf einer Platine oder einem Gehäuse befestigt werden können.

Daneben gibt es noch die Größen XT30 und XT90, beide habe ich aber noch nicht mit mechanischen Befestigungen gesehen. XT30 gibt es auch in einer dreipoligen Variante, ebenfalls verpolungssicher. Bei ebay findet man sowas.

Die Flachstecker haben halt den Nachteil, daß man es auch mal falsch machen kann.

Bin am Überarbeiten der Hauptplatine. Die Buchsenleisten sind inzwischen so ausgeleiert, daß das Ding reichlich Wackelkontakte hat. Außerdem hat es mir, ohne daß ich einen Grund wüßte, das dritte e-Paper zerschossen.

Beim Testen mit den Jumperkabeln fiel mir auf, daß der Prozessor einwandfrei arbeitete, wenn man die belegten Pins mit der Fassung verbindet. Steckte man die Platine mit allen Pins in die Fassung, ging es nicht mehr...

Dann jeden Anschluß gegen die jeweiligen Nachbarpins per Widerstandsmessung geprüft:

Einen Kurzschluß gefunden und beseitigt, aber praktisch alle Pins hatten eine meist hochohmige Verbindung zu den Nachbarn. Das Platinenmaterial entwickelt offensichtlich Leitfähigkeiten durch das Löten. Manche Widerstände lagen bei nur noch 250kOhm. Hält man den Lötkolben an solche Pins, sinkt der Widerstand erstmal deutlich und steigt dann beim Erkalten meist auf Werte über 1,3M.

Eine solche Stelle hat dann auch das Starten des Arduino verhindert. Komischerweise lief er weiter, wenn man während des Betriebs die entsprechende Leitung verbunden hat. Ich fürchte, ich muß das Ganze nochmal aufbauen, aber auf Platinen mit geeigneterem Material.

Die Dinger von mir waren durchaus teuer, sind entweder schwarz oder weiß eingefärbt und bestehen angeblich aus GFK.

Die BS3002 sind eingetroffen, werde sie bei Gelegenheit mal in einem Schalter verbauen.

George67 am 15 Apr 2020 08:13:03

Besorg dir ne Weller Lötstation, oder Erde die Spitze.
Welches Lot verwendest du, Blei oder ROHS? Welchen Durchmesser?
Mach bitte ein Foto deiner Lötstellen, ich will die Verschmutzung durch Flussmittel sehen.
Reinige die Platine nach dem Löten mit Spiritus und Pinsel von den Flussmittel Resten.
XT30, oder 60, hab ich da, aber bin damit nicht zufrieden. Vielleicht hast du trotzdem Recht damit. Gibt's die für liegende Montage am Platinenrand?

SMD löten geht, ich hab ja nur 1206 genommen, das geht noch. Im Notfall auch 0805. Ich mach das ja auch schon länger. Pinzette, Platinen Halterung, Beleuchtung und Nahbrille ist ein Muss, Lupe zur Kontrolle auch. Ganz dünnes Lötzinn.

Profis meiner Firma machen auch 0403, unter der Lupe... wenn es sein muss.

Schwierig ist SMD auf der normalen Lochraster Platine, schau dir den Schalter und die Ansteuerung an :D

rkopka am 15 Apr 2020 09:34:31

George67 hat geschrieben:Schwierig ist SMD auf der normalen Lochraster Platine, schau dir den Schalter und die Ansteuerung an :D

Für "normale" Bauteile braucht man es zum Glück selten (R,C). Für ICs gibts eine Menge Adapterplatinen günstig und für fast jede Bauform, damit man sie im normalen Raster verwenden kann. Hab ich für einige Chips verwendet, die es nur in SMD gab. Bei BGA ist dann aber Schluß :-).

RK

George67 am 17 Apr 2020 14:52:27

Musterplatinen sind beim Drucker.

Albrecht0803 am 19 Apr 2020 23:03:33

Nach weiterer Betrachtung der Schaltung stellten sich noch ein paar ungünstige Eigenschaften raus:

Als erstes: Tests ohne beidseitig angeschlossener Masseleitung des Bucks führt zu undefiniertem Potential der 40V-Seite. War möglicherweise die Ursache einiger der aufgetretenen Schäden.

Zweitens, ganz besonders übel: Das Einschalten der Heizung, wenn einerseits die Ladebedingung erfüllt und gleichzeitig die Temperatur unter dem Schwellenwert liegt, trennt ebenfalls die boosterseitige Masseleitung. Die buckseitige Masseleitung ist in diesem Zustand über die Relais stillgelegt. Ergebnis: Undefiniertes Potential der 40V-Seite, mit Spannungen jenseits der Verträglichkeit einiger Bauteile.

Um die ganze Platine nicht grundlegend redesignen zu müssen, wird die Heizung so geschaltet, dass sie die Masseleitung des Boosters nicht mehr unterbricht. Um das Laden zu unterbinden, werden auf der Softwareseite die Buck-Boost-Umschaltrelais so gesteuert, daß bei Ladebedingung und Heizungsanforderung gleichzeitig erfüllt —> die Heizung eingeschaltet, aber der Booster nicht aktiviert wird. Stattdessen bleibt der Buck aktiv, wie bei normalem Stützbetrieb. Da trotzdem Ladespannung anliegt, sollten allenfalls geringe Stützströne seitens des Li-Akkus anfallen.

Sobald die Temperatur hoch genug ist, wird die Heizung abgeschaltet und der normale Ladevorgang über den dann aktivierten Booster geschaltet.

Was bleibt an offenen Punkten? Die undefinierte Potentialsituation kann während der Schaltphase der 4 Relais immer noch auftreten, je nachdem, wie und in welchem Zeitversatz die Kontakte der Relais schalten. Vielleicht kann man diesem Problem mit ein paar kräftigen Kondensatoren abhelfen? Es geht ja nur um sehr kurze Zeiten undefinierter Zustände.

Die notwendigen Änderungen der Hauptplatine sind fertig. Die Arduino-Steuerplatine ebenfalls. Letztere hat einen zweiten Anschluß für das e-Paper bekommen, mit zwischengeschalteten Pegelshiftern, so daß jetzt wahlweise mit 3,3 oder 5V gearbeitet werden kann. Der Umbau der Mosfet-Schalter auf die BS3002-Fets ist auch noch nicht erfolgt.

Tests all dieser Änderungen stehen noch aus. Es scheint außerdem so, daß ich wohl die letzten in Europa vorrätigen Displays dieser Größe gekauft und geschrottet habe. Die Lieferanten warten auf Nachlieferung aus China, genau wie ich....

Fotos von den Lötstellen kommen noch. Vorab, grade toll sehen die nicht grade aus. Bin halt bekennender Theoretiker......-
Lötzinn ist eine Rolle Stannol, ich denke es ist das neue bleifreie Zeug. Anderes bekommt man neu ja nicht mehr.

rkopka am 19 Apr 2020 23:21:11

Albrecht0803 hat geschrieben:Lötzinn ist eine Rolle Stannol, ich denke es ist das neue bleifreie Zeug. Anderes bekommt man neu ja nicht mehr.

Da --> Link schon. Bei Conrad hab ich auch keines mehr auf der Homepage gesehen. Ich dachte für Reparaturzwecke soll es das noch länger geben ? Muß ich doch noch welches einlagern, bzw. mal lernen mit dem neuen zu löten.

RK

Albrecht0803 am 20 Apr 2020 10:45:02

Danke, RK!

habe mir dort gleich zwei Rollen bestellt.

George67 am 20 Apr 2020 15:54:21

Militär und Medizintechnik darf Bleizinn weiter verwenden.
Ist eben doch zuverlässiger und mit größerem Prozessfenster.
Löten?
Das Zinn muss Benetzen, wie man das beim Wasser kennt. Und genauso muss die Zinnkante aussehen und sich verhalten.
Liegt die Zinnkante auf wie Wasser auf Fett, isses schlecht. Schmiegt sie sich an, wie Wasser auf benetzten Flächen, isses gut.
Deswegen immer beide Seiten vorverzinnen, direkt am Loetdraht.
Dann erst zusammenhalten, und wieder mit frischem Zinn vom Loetdraht. Da ist Flussmittel drin, das wirkt nur 3 Sekunden.

George67 am 21 Apr 2020 10:54:08

Albrecht0803 hat geschrieben:
Als erstes: Tests ohne beidseitig angeschlossener Masseleitung des Bucks führt zu undefiniertem Potential der 40V-Seite. War möglicherweise die Ursache einiger der aufgetretenen Schäden.

Sorry, aber ich sagte es mehrfach - unterbrochene Masse ist immer böse.
Ein Tipp - ich hadere immer noch mit dem Booster, weil er selber die Verbindung auch unterbricht. Ich habe vor zu testen, ob man die beiden Masseklemmen des Booster mit zwei antiparallelen Dioden brücken kann, ohne die Funktion zu stören.
Habs aber noch nicht testen können.

Und btw - die Platinen für den Mosfetschalter sind gekommen!!

Albrecht0803 am 21 Apr 2020 15:39:03

Ja, das sagtest Du, und vermutlich zu recht. Das mit dem Booster ist auch bei mir ein Problem, der schaltet die Masseleitung erst bei Bedarf durch. Ansonsten könnte man sich ja mit Deiner früher vorgeschlagenen „Reihenschaltung“ der Masseleitungen von buck und boost behelfen. Das hat mit meinem Booster nicht geklappt, weil die Masseleitung des nicht aktiven Boosters keinen Durchgang hat.

Mit der Relaissteuerung kann es während des Umschaltens zu einer Unterbrechung der Masseleitungen kommen. Abhilfe, wenngleich mit einer abermaligen Neukonzeption der Hardware, könnte per Arduino und Ansteuerung von Einzel-Schließer-Relais erfolgen. Damit kann man per Software sicherstellen, daß die Masseleitungen zeitlich überlappend durchgeschaltet sind.

Ich werde zunächst versuchen, die nur kurzzeitigen Unterbrechungen mit einem Kondensator zu puffern, damit in diesen Zeitspannen die Spannungen nicht nach weiß Gott wohin vagabundieren. Sollte das nicht klappen gibt es halt die Arduino-Software-Lösung.

Albrecht0803 am 21 Apr 2020 23:41:03

Showtime!


















Das ist der aktuelle Stand. Es werden jetzt sukzessive die Arduino Anschlüsse zunächst gemessen, wenn ok,mit Kabeln verbunden. Nach jedem Teilschritt dieser Art werden am Notebook die vom Arduino gemessenen Spannungen und Ströme ausgegeben. Wenn der letzte Anschluß dran ist und alles noch funktioniert, sollte man durch sein....

George67 am 22 Apr 2020 07:48:06

Im Moment plane ich immer noch mit der Reihenschaltung der Masse von Buck und Booster, aber du hast Recht, ich muss mir das als nächstes anschauen.
Momentan habe ich 7 Mosfetschalter, zwei davon für 30 A, einer davon mit 4110 wegen Spannungsfestigkeit für 48 Volt Akkuspannung. Der soll den Inverter schalten.
Schau dir die Schaltspannung der BS 3002 an, die schalten zwar ab 4 Volt, brauchen aber 8 V um richtig niederohmig zu werden.
Und probiere Mal die Antiparallel en Dioden statt der Kapazität. Beim Booster.

George67 am 22 Apr 2020 17:43:12

Zur Showtime:
Zum einen - ich habe große Achtung dafür, an was für ein Projekt du dich da herangewagt hast. Alle Achtung!
Zum anderen, ich finde es erschreckend, was für einen Riesenaufwand - verglichen mit der Kiss-Version - der Wunsch nach Anzeigen und programierbarer Steuerung mit sich bringt.

Mein geplanter Aufbau sieht etwas anders aus, er ist etwas modularer und etwas "mechanischer" geplant, das ändert aber auch nichts daran, welcher Aufwand sich ergibt. Ich sagte ja schon: 7 Mosfetschalter - momentan.

Zum Aufbau: Da steckt viel Arbeit drin - und man merkt auch (positiv), dass das nicht die erste Version ist.

Einige Anmerkungen:
Die Lötstellen sind - unter Berücksichtigung des Reinzinn - garnicht so schlecht.
Ich würde aber die Bauteile in den Lochrasterplatten immer am Kupferring des Loches fest und ordentlich verlöten, aus mechanischen Gründen. Beispiel Bild 3, der einzelne Widerstand hängt unverlötet im Loch.
Die Unterseite des Mosfetschalters Bild 3: Abgesehen vom Zinnproblem ist das echt ok, dicke Kupferleitungen auf Lochraster sehen nie "schön" aus, sie sollen Strom leiten und rüttelfest sein.
Die Relaisverdrahtung ist echt ordentlich.
Die Arduinoplatine, Bild 1, mit den isolierten Drähten ist echt gut gemacht. Sowas ist nichts für Auge, aber hält ewig.
Unterseite Hauptplatine - dito, das könnte man schöner hinbekommen, mit entsetzlichem Aufwand - aber warum ? Elektrisch ist das sehr gut. Zumindest dann, wenn du die Lochringe etwas mehr mit einbeziehst. Dann sehen die Lötstellen automatisch auch besser aus. Lotmenge ist nicht zuviel, wenn sie sich noch über die Löcher erstreckt.
Die Freilaufdioden sind wahrscheinlich nicht gut. Die sehen aus wie Hochstromdioden, die etwas langsamer umschalten. Da können Spannungsspitzen überbleiben. Auch 1N4001 sind eigentlich zu langsam, du brauchst etwas schnelleres, es braucht auch nur weniger Strom zu können. Freilaufdioden haben maximal den Strom des Relais, nicht mehr. 1N4148 wär ok, oder so ähnlich und schnell.
Rückseite Steuerplatine, würdest du die Ringe ordentlich mit verlöten (und ordentlich verzinnen, vorher !) oder wenigstens beim Löten, würde es auch hübsch aussehen. Gerade Drähte ist nicht nötig, die müssen gut liegen, das reicht und ist ok so.
Löte das folgendermassen: leg die Lötspitze so an den Draht, dass sie gleichzeitig auch den Ring mit berührt. 2-3 Sek heizen, ausprobieren. DANN erst in den Spalt zwischen Spitze, Draht und Ring das Lötzinn reinschieben, und zwas soviel, dass das Zinn am Draht hoch und um den Ring herumläuft. Voila! Wenn einer von beiden schlecht benetzbar ist - vorverzinnen.
Das Lot ist ok, mit Flussmittel, eben Reinzinn. Du wirst sehen, dass Bleizinn viiiiel schönere Lötstellen macht. Und zuverlässigere.
Drähte auf Länge knipsen übrigens vorm Löten, nicht hinterher !!

-------------------
Das ganze Geraffel macht mich nochmal zweifeln, ob man die Wandler überhaupt über Ein-Ausgang steuern sollte. Vielleicht sollte man doch die Enable-Eingänge der IC nach aussen legen und daran die Wandler steuern.

Werd ich mir nochmal überlegen.

George67 am 22 Apr 2020 20:25:25

Ich hab das Masseproblem geklärt. Du kannst die doppeldiode benutzen.

Albrecht0803 am 23 Apr 2020 00:11:35

Hi Georg, Danke für die Hinweise.

Mit den Freilaufdioden hast Du schon recht. Ich habe einfach die dicksten aus der Kiste genommen, weiß noch nichtmal deren Typ. Kann ich aber leicht gegen passendere ersetzen.

Das Problem, hauptsächlich mit der Hauptplatine ist, daß jegliche Reparatur die Lötaugen ziemlich versaut. Es ist fast unmöglich, eine zugelötete Bohrung wieder frei zu kriegen, um z.B. ein defektes Bauteil zu ersetzen. Bin deshalb zunehmend dazu übergegangen, die Drähte zunächst nicht mit den Lötaugen, sondern direkt auf der Rückseite zu verbinden. Das macht Reparaturen einfach, ist aber natürlich nicht das Solideste.

Die Doppeldiode soll die In- und Outputpunkte der Minus-Anschlüsse des Boosters verbinden, habe ich das so richtig verstanden? Über die Dioden kann sich in beiden Richtungen höchstens eine Spannung von 0,7V aufbauen, was die Strommessung des Boosters vermutlich nicht stört.

Andererseits verliert man im Autarkiebetrieb über diesem Spannungsabfall mal Stützstrom doch an Leistung, zumindest, wenn man die Reihenschaltung der Masseleitungen verwirklicht. Bei meiner Relaisvariante könnte die Masseleitung des Boosters mit der Doppeldiode immer durchgeschaltet bleiben, während der Buck nur im Stützbetrieb verbunden ist, im Ladebetrieb dagegen nicht. Das wäre dann nicht mit zusätzlichen Verlusten verbunden. Werde die Schaltung dahingehend verändern.

Was den Aufwand angeht, ist das relativ. Ich hatte von Anfang an geplant, Buck und Booster mit dieser Relais-Schaltung alternativ zu aktivieren. Das war vielleicht nicht die beste Idee, führte aber dazu, daß ich insgesamt im Lauf der Zeit fast zehn Hauptplatinen dieser Bauart in Richtung Schrottkiste verbaut habe. Auch eine größere Anzahl der analogen Spannungssensorik läßt sich noch in der Restekiste auffinden.

Vor diesem Hintergrund ist die Anzahl der Arduino-Steuerplatinen (aktuell die dritte) recht gering, das hat praktisch auf Anhieb funktioniert. Die Messtechnik mit Anzeigen auf dem e-Paper ist nicht notwendig, mehr ein Ausdruck von Eitelkeit, einfach weil es möglich ist und der Arduino sich nicht mehr als nötig langweilen soll.

Hoffe, das Projekt jetzt langsam abschliessen zu können, auch deshalb, weil die Beschäftigung mit dem Arduino eine endlose Reihe von Ideen im Hinterkopf erzeugt hat, die alle angegangen werden sollen.

z.B. eine kostengünstige elektronische Instrumentierung für ein Sportflugzeug, mit allem, was man braucht oder auch nur gerne hätte:

Künstlicher Horizont, Motor- und Treibstoffmanagement, automatisches Flugbuch, GPS-gesteuert, Höhenmesser, Variometer, Fahrtmesser auf digitaler Basis, Errechnen des aktuellen Windes, Richtung und Geschwindigkeit aus den Daten eines magnetischen Sensors und GPS-Vektordaten, autark von den üblicherweise über Funk angesagten Werten. Die Höhenmessereinstellung könnte man sich auch noch vornehmen: Entweder per Stimmerkennung des QNH-Wertes im Flugfunk, oder durch autarke Schätzung über die GPS-Höhe....

Dann ein Drohnenprojekt, das Drohnen zu meßtechnischen Zwecken über beliebig lange Zeiträume an feststehenden Meßpunkten an den Himmel nagelt (mehrere Drohen, die sich nach Erschöpfung der Akku-Ladung jeweils abwechseln). Man sieht, der Fast-Rentner hat wahrscheinlich mehr Pläne, als er schaffen kann.

Albrecht0803 am 23 Apr 2020 21:25:53

Habe mir einen etwas kleineren Booster bestellt, der heute eingetroffen ist.
—-> Link:

--> Linkärtswandler-Modul/362969972722?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

Der hat auf der Masseleitung Durchgang. Vielleicht nur einen Shunt zur Stromregelung, obwohl ich einen solchen auf der Platine nicht identifizieren konnte. Es gibt 2 Potis, RV1 und RV2, mit denen man hoffentlich Strom und Spannung einstellen kann. Probiert habe ich es noch nicht, nur den Widerstand auf der Massestrecke mal gemessen.

Mit diesem Booster sollte auch die Reihenschaltung funktionieren.

rkopka am 23 Apr 2020 21:58:29

Albrecht0803 hat geschrieben:Vielleicht nur einen Shunt zur Stromregelung, obwohl ich einen solchen auf der Platine nicht identifizieren konnte.

Ziemlich sicher der R010 ganz links neben den Schraubkontakten.

RK

Albrecht0803 am 23 Apr 2020 23:00:26

Ja, kann sein. Ich hatte nach einer Drahtbrücke wie bei dem größeren Booster gefahndet.....


  • Die neuesten 10 Themen
  •  
  • Die neuesten 10 Reiseberichte
  • Die neuesten 10 Stellplätze

TinyBMS der Fa Faktor
zusätzliche Batteriesicherung bei LiFePo4
Alle Rechte vorbehalten ©2003 - 2020 AGB - Datenschutzerklaerung - Kontakt